Provide a button to trigger database maintenance

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: Natch, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
bug 431558 introduces a new module to prevent database corruption. As of the latest patch there the maintenance is triggered on an idle timer. There should be a way for a user to trigger the maintenance manually should his/her database become corrupted.
WONTFIX?  This sounds like addon material to me as this won't need to be done by most users ever.
(Reporter)

Comment 2

10 years ago
Well the only reason I proposed this was because of the mass reports of database corruption, and since the module is being included anyhow, why not make it somewhat accessible to an end user, so that the answer to database corruption won't be "open your browser and leave it alone for 10 minutes".
The database corruption that is being reported wouldn't be fixed by this...
this goes with the "provide a compact database button", so i would say not WONTFIX for now, until we get a decision on both of them.
not late-l10n for now though, since this is not targetted
Keywords: late-l10n
I *really* *really* think we don't want to expose our users to this

Comment 7

10 years ago
This seems like an enhancement.
Severity: normal → enhancement
Version: unspecified → Trunk
>I *really* *really* think we don't want to expose our users to this

Yes, I really agree, which makes for a whole lot of reallys.  I'm reminded of the "Force Garbage Collection" button in Eclipse's about window.  Whatever we need to do fix user's database, we need to do it automatically and transparently.  Something that never breaks is obviously a lot better than having a "don't be so broken" button for people to hit.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Keywords: uiwanted
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.