Password not saved on some pages

RESOLVED WONTFIX

Status

Camino Graveyard
HTML Form Controls
--
minor
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: Pierre Rudloff, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; fr; rv:1.8.1.18) Gecko/20081112 Camino/1.6.5 (MultiLang) (like Firefox/2.0.0.18)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; fr; rv:1.8.1.18) Gecko/20081112 Camino/1.6.5 (MultiLang) (like Firefox/2.0.0.18)

Camino doesn't always ask for the password to be saved.

Reproducible: Always

Steps to Reproduce:
1.Go to https://hotspot.neuf.fr/
2.Type an username and a password and check the box
3.Connect
Actual Results:  
Camino doesn't ask if I want to save the password.

Expected Results:  
Camino should ask if I want to save the password.

I think this is mainly on securised webpages.

Comment 1

9 years ago
What's going on here is that the username and password field aren't in the form that is submitted. Instead, there's a form with nothing but type="hidden" fields, and they are populated from the text fields by javascript.

Closing WONTFIX because there's no robust way of handling really bizarre edge-cases like this, and adding lots of specific one-off handling for individual sites isn't a direction we want to go.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

9 years ago
So is there a way to manually add the entry in the keychain so I don't have to type my password each time I want to connect ?
(Reporter)

Comment 3

9 years ago
I manually added the password to the keychain.
Safari is now filling the form, but Camino isn't.
You need to log in before you can comment on or make changes to this bug.