TM: Freezes with jit.content enabled [@ nanojit::Assembler::asm_store32]

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

({fixed1.9.1, hang})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-tracemonkey, )

Attachments

(1 attachment)

We get a slow script dialog on this site because assembler errors don't blacklist, so we keep trying to compile a long trace that fails every time.
Posted patch proposed fixSplinter Review
Assignee: general → danderson
Status: NEW → ASSIGNED
Attachment #351290 - Flags: review?(gal)

Comment 2

11 years ago
Whats the cause of the assembler error? If we just accidentally run out of memory I am not sure we want to blacklist.
This is from bug 460511 where the reservation table gets filled.

Updated

11 years ago
Attachment #351290 - Flags: review?(gal) → review+
Pushed fix as changeset: http://hg.mozilla.org/tracemonkey/rev/68a4eb0bcf48

Requesting blocking flag since this is really an unpleasant bug.
Severity: enhancement → normal
Flags: blocking1.9.1?
Whiteboard: fixed-in-tracemonkey

Updated

11 years ago
Flags: blocking1.9.1? → blocking1.9.1+

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite-
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.