Last Comment Bug 467874 - cairo calls FT_Done_Face on FT_Faces for unscaled_fonts created from_face
: cairo calls FT_Done_Face on FT_Faces for unscaled_fonts created from_face
Status: RESOLVED FIXED
: fixed1.9.1
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: mozilla1.9.1b3
Assigned To: Karl Tomlinson (:karlt)
:
:
Mentors:
http://bugs.freedesktop.org/show_bug....
: 490032 (view as bug list)
Depends on:
Blocks: 458169 490032 520030
  Show dependency treegraph
 
Reported: 2008-12-03 21:02 PST by Karl Tomlinson (:karlt)
Modified: 2009-10-01 15:31 PDT (History)
17 users (show)
vladimir: blocking1.9.1+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch for moz cairo [pushed to m-c][pushed to 1.9.1] (2.21 KB, patch)
2008-12-03 21:10 PST, Karl Tomlinson (:karlt)
vladimir: review+
Details | Diff | Splinter Review

Description Karl Tomlinson (:karlt) 2008-12-03 21:02:09 PST
This would cause random crashes in FT_Done_Face or FT_Set_Transform after browsing pages with @font-face { src: url() } when bug 458169 is landed, so we'll want the fix landed before an upstream fix and moz cairo upgrade.
Comment 1 Karl Tomlinson (:karlt) 2008-12-03 21:10:59 PST
Created attachment 351320 [details] [diff] [review]
patch for moz cairo [pushed to m-c][pushed to 1.9.1]
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2008-12-04 02:54:36 PST
Do you want to request review here? Vlad if no-one else springs to mind.
Comment 3 Karl Tomlinson (:karlt) 2008-12-04 14:07:11 PST
Comment on attachment 351320 [details] [diff] [review]
patch for moz cairo [pushed to m-c][pushed to 1.9.1]

Behdad, this is the same patch as on the freedesktop bug.  Do you see any problem with doing this?
Comment 4 Behdad Esfahbod 2008-12-04 14:10:11 PST
The patch looks correct.  I was going to commit upstream last night when I noticed that I need to do some refactoring as the check doesn't belong into the function it modifies.  But functionality wise it's correct.
Comment 5 Karl Tomlinson (:karlt) 2008-12-05 22:04:32 PST
Comment on attachment 351320 [details] [diff] [review]
patch for moz cairo [pushed to m-c][pushed to 1.9.1]

http://hg.mozilla.org/mozilla-central/rev/e8d254e47322
Comment 6 Karl Tomlinson (:karlt) 2008-12-05 22:06:05 PST
Fixed on mozilla-central.
Still needs to land on 1.9.1.
Comment 7 Karl Tomlinson (:karlt) 2008-12-10 21:53:08 PST
Comment on attachment 351320 [details] [diff] [review]
patch for moz cairo [pushed to m-c][pushed to 1.9.1]

http://hg.mozilla.org/releases/mozilla-1.9.1/rev/c871aaeafc34
Comment 8 Karl Tomlinson (:karlt) 2008-12-10 21:59:41 PST
Distributions that build 1.9.1 Beta 3 with --enable-system-cairo will need this fix in their cairo.
Comment 9 Fabien Tassin 2008-12-15 04:19:28 PST
Is it fixed upstream too? I can't find it in the 1.8.6 release notes.
Comment 10 Karl Tomlinson (:karlt) 2008-12-15 12:23:31 PST
(In reply to comment #9)

This is being tracked upstream here:
http://bugs.freedesktop.org/show_bug.cgi?id=18862
Comment 11 Bill McGonigle (not currently reading bugmail; please contact directly) 2009-05-22 16:27:07 PDT
*** Bug 490032 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.