File is still accessed after upload

RESOLVED DUPLICATE of bug 183689

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 183689
10 years ago
10 years ago

People

(Reporter: Robert Klemme, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

When I upload a file (for example as bugzilla attachment) the file is still accessed after the upload finishes.  When I try to delete it, Windows reports that the file is being used by another person or program.  This seems to happen every time and so far I could only resolve this by closing FF completely.

Reproducible: Always

Steps to Reproduce:
1. Upload a file attachment to bugzilla or any other website
2. Wait until the upload finishes, do not close the browser.
3. Try to delete the file via Windows Explorer.
Actual Results:  
The file cannot be deleted.

Expected Results:  
The file can be deleted.

FF is configured to use a proxy and I am behind a corporate firewall. The proxy seems to be a squid/2.6.STABLE.19 according to HTTP response headers.

I'll classify as normal bug because a) it may lead to file handle issues or b) there could be a general file handling issue in FF.  Please do not hesitate to change severity to minor if you detect this issue cannot have serious impacts.
(Reporter)

Comment 1

10 years ago
Created attachment 351363 [details]
Error screenshot

Screenshot showing the error message.
(Reporter)

Comment 2

10 years ago
Setting version to branch 3.0 (I am using 3.0.4).

Additional remark: I verified that several files are still accessed, i.e. the newest upload does _not_ free the file still accessed from the last upload. Instead, both files cannot be accessed.  Looks like a potential resource leak for long running browser sessions.
Version: unspecified → 3.0 Branch

Comment 3

10 years ago
Are you using LiveHTTPHeaders ? That is know to cause this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 183689
(Reporter)

Comment 4

10 years ago
Yes, I use LiveHTTPHeaders 0.14. Thanks for the heads up, Jo!
You need to log in before you can comment on or make changes to this bug.