Mozilla crashes when opening and closing windows

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
critical
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Mitja, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (WinNT; U)
BuildID:    2000071920

Mozilla crashes when first to links in google search for "stereograms" are 
opened and then closed

Reproducible: Always
Steps to Reproduce:
//1. search in google for "stereograms" (this can be skipped)
2. open first two links (http://skal.planet-d.net/sis/sis.ang.html, 
http://www.nottingham.ac.uk/~etzpc/sirds.html)
3. close both windows


Actual Results:  Mozilla crashed

Expected Results:  ...

This bug is also in Netscape 4.7
Talkback ID: TB14912104Y

Comment 1

18 years ago
WFM on build 20000727 on Win2k
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 2

18 years ago
stack trace from talkback report:
   MSVCRT.dll + 0xd0b9 (0x7800d0b9)


   MSVCRT.dll + 0xcc1c (0x7800cc1c)


   PR_Free
                                              [prmem.c, line 68]

   nsMemoryImpl::Free

[d:\builds\seamonkey\mozilla\xpcom\base\nsMemoryImpl.cpp, line 140]

   nsMemory::Free

[d:\builds\seamonkey\mozilla\xpcom\base\nsMemoryImpl.cpp, line 246]

   nsStr::Free

[d:\builds\seamonkey\mozilla\xpcom\ds\nsStr.cpp, line 687]

   nsStr::Destroy

[d:\builds\seamonkey\mozilla\xpcom\ds\nsStr.cpp, line 91]

   nsString::~nsString

[d:\builds\seamonkey\mozilla\xpcom\ds\nsString2.cpp, line 150]

   nsStyleContextData::~nsStyleContextData

[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleContext.cpp, line 2084]

   StyleContextImpl::`scalar deleting
   destructor'


   nsXMLContentSink::Release

[d:\builds\seamonkey\mozilla\layout\xml\document\src\nsXMLContentSink.cpp, line 261]

   FrameManager::ComputeStyleChangeFor

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1461]

   nsCSSFrameConstructor::ContentStatesChanged

[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 9929]

   StyleSetImpl::ContentStatesChanged

[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleSet.cpp, line 1131]

   PresShell::ContentStatesChanged

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3365]

   nsXULDocument::ContentStatesChanged

[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 1623]

   nsEventStateManager::SetContentState

[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 2249]

   nsEventStateManager::GenerateMouseEnterExit

[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 1441]

   nsEventStateManager::PreHandleEvent

[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 297]

   PresShell::HandleEventInternal

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3988]

   PresShell::HandleEvent

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3928]

   nsView::HandleEvent

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 782]

   nsViewManager2::DispatchEvent

[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1389]

   HandleEvent

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]

   nsWindow::DispatchEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 564]

   nsWindow::DispatchWindowEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 581]

   nsWindow::DispatchMouseEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3689]

   ChildWindow::DispatchMouseEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3894]

   nsWindow::ProcessMessage

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2809]

   nsWindow::WindowProc

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 830]

   USER32.dll + 0x124c (0x77e7124c)


I'm unable to reproduce this crash with 072808 M18 mozilla build on NT.
Reporter, can you reproduce this crash with a current talkback build (if so can
you include the talkback ID again)
(Reporter)

Comment 3

18 years ago
Tested on build 2000072920. The problem seems gone.
Status: RESOLVED → CLOSED
(Assignee)

Comment 4

18 years ago
reopening to Verify.  Thanks for the followup.  (bugs don't get closed till we ship)
Status: CLOSED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Comment 5

18 years ago
resolving worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

18 years ago
verifying WFM per reporter's comments.  
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.