drag and drop subfolder to root of account is blocked/fails

VERIFIED FIXED in Thunderbird 3.0b2

Status

Thunderbird
Mail Window Front End
VERIFIED FIXED
9 years ago
7 years ago

People

(Reporter: wsmwk, Assigned: Ian Neal)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Thunderbird 3.0b2
regression
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081204 Thunderbird/3.0b1

drag and drop subfolder to root of account is blocked/fails. i.e. drag a local second level folder (subfolder) to local account to make it a first level folder

result: operation shows the drop is blocked

works if dragging subfolder to another folder

Comment 1

9 years ago
This is true on Mac too! Build 3.0b2pre

Comment 2

9 years ago
Regression from tb2, and quite limiting, as there's no way to move back a folder other than dragging and dropping, in case you move it accidentally.
Flags: blocking-thunderbird3+
Keywords: regression
OS: Windows Vista → All
Hardware: x86 → All

Updated

9 years ago
Duplicate of this bug: 471162
(Assignee)

Comment 4

9 years ago
The reason is that the new code checks .canFileMessages regardless if it is a message or folder - http://mxr.mozilla.org/comm-central/source/mail/base/content/folderPane.js#343
The old code used to do that check as well as a lot more.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
(Assignee)

Comment 5

9 years ago
Created attachment 357240 [details] [diff] [review]
Only check .canFileMessages for messages patch v0.1 (Checkin: Comment 9)

This patch makes canDrop only check .canFileMessages when the drop types are messages.
(Assignee)

Updated

9 years ago
Attachment #357240 - Flags: review?(mkmelin+mozilla)
(Reporter)

Updated

9 years ago
Blocks: 414038
(Assignee)

Updated

9 years ago
Blocks: 465015
(Assignee)

Comment 6

9 years ago
There are other checks we probably still need to do for messages that were in the old code:
targetFolder.isServer and checking not dropping into folder it is already in.

Updated

9 years ago
Attachment #357240 - Flags: review?(mkmelin+mozilla) → review+

Comment 7

9 years ago
Comment on attachment 357240 [details] [diff] [review]
Only check .canFileMessages for messages patch v0.1 (Checkin: Comment 9)

Thx, r=mkmelin
(Assignee)

Updated

9 years ago
Attachment #357240 - Flags: superreview?(bienvenu)

Updated

9 years ago
Attachment #357240 - Flags: superreview?(bienvenu) → superreview+

Comment 8

9 years ago
Comment on attachment 357240 [details] [diff] [review]
Only check .canFileMessages for messages patch v0.1 (Checkin: Comment 9)

thx for the patch!
(Assignee)

Updated

9 years ago
Attachment #357240 - Attachment description: Only check .canFileMessages for messages patch v0.1 → Only check .canFileMessages for messages patch v0.1 (Checkin: Comment 9)
(Assignee)

Comment 9

9 years ago
Comment on attachment 357240 [details] [diff] [review]
Only check .canFileMessages for messages patch v0.1 (Checkin: Comment 9)

http://hg.mozilla.org/comm-central/rev/47815c10e304
(Assignee)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Target Milestone: --- → Thunderbird 3.0b2
(Reporter)

Comment 10

9 years ago
thanks Ian. 
verified 2009-01-24 build
Status: RESOLVED → VERIFIED
Blocks: 510793
You need to log in before you can comment on or make changes to this bug.