new version of Yahoo mail blocks Shiretoko on user agent string

VERIFIED DUPLICATE of bug 334071

Status

VERIFIED DUPLICATE of bug 334071
10 years ago
4 years ago

People

(Reporter: notforyourmail, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081205 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081205 Shiretoko/3.1b3pre

Yahoo mail will not let you use their newer (AJAX) interface if you are using the Firefox 3.1 beta.  They block it as an unsupported browser.  Setting the user agent string to the string for older versions of Firefox makes mail work perfectly.

Reproducible: Always

Steps to Reproduce:
1.  Run the latest 3.1 beta
2.  Go to mail.yahoo.com  (it may help to delete your cookies for mail.yahoo.com if you have any.)
3.  Log in, and attempt to use new mail interface
4.  Get a message from yahoo saying the browser is blocked because it is unsupported.  The message suggests that you use another browser, and gives you the option of using mail with the old interface.
5.  Switch the user agent string to that of an older version of Firefox (say, 3.0.4).
6.  New yahoo mail interface works perfectly.
Actual Results:  
Get a message from yahoo saying the browser is blocked because it is unsupported.  The message suggests that you use another browser, and gives you the option of using mail with the old interface.

Expected Results:  
Should be able to use Yahoo Mail with the new interface.

Updated

10 years ago
Assignee: nobody → english-us
Component: General → English US
OS: Mac OS X → All
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Hardware: Macintosh → All

Comment 1

10 years ago
Dupe of bug 448184, bug 334071.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 334071

Updated

10 years ago
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.