Using "Save As" on a page with hundreds of images when working offline gives hundreds of blank dialogs and not all images saved

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Silas S. Brown, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-12-01])

Attachments

(11 attachments)

512.00 KB, application/octet-stream
Details
512.00 KB, application/octet-stream
Details
512.00 KB, application/octet-stream
Details
512.00 KB, application/octet-stream
Details
512.00 KB, application/octet-stream
Details
512.00 KB, application/octet-stream
Details
512.00 KB, application/octet-stream
Details
512.00 KB, application/octet-stream
Details
512.00 KB, application/octet-stream
Details
512.00 KB, application/octet-stream
Details
56.85 KB, application/octet-stream
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

I scanned a document and split it into individual images of words using my Image Reflow utility http://people.pwf.cam.ac.uk/ssb22/notes/#reflow and put this on a web server and pointed Firefox at it.  The page loaded OK no problem.  Unfortunately, the web server later went down, and I urgently needed to get the document across to a different computer.  The only copy I had now was in Firefox's memory.  So I set Firefox to Work Offline and tried File / Save As.  That is, attempting to save a page that has hundreds of images in it.  Result, I got hundreds of blank dialogs, and not all images were saved (about 200 of them were saved OK, the rest were not).  They are all present and correct in the browser window so I know they must be there somewhere.  I don't know what determines which ones were saved OK and which were not.

The blank dialog boxes had no message, just 2 buttons (with no labels on the buttons either).  The Downloads window cannot be clicked on due to the dialog boxes.

Reproducible: Always

Steps to Reproduce:
1. Load a page with hundreds (preferably thousands) of small images
2. Work offline.  Verify all images are still there in the browser window.
3. Save the page
Actual Results:  
Not all images saved; hundreds of blank dialog boxes are displayed.

Expected Results:  
All images that were in the memory should be saved; no blank dialog boxes should be displayed (or at least the dialog boxes should be informative).
can you provide a url to the problem page? Also, please try this with a new profile: http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows
(Reporter)

Comment 2

9 years ago
I have a page which will demonstrate the bug, it has an index.html and a couple of thousand small PNG images.  Unfortunately I do not have enough quota on a suitably well-connected webserver to be able to store it for guaranteed long-term reference.  So I'll attach it.  But the maximum size of attachments is 512 K and the zip is 5.1 Megabytes  Therefore I will split the zip file into 512K blocks.  Download all blocks, cat them into a zip file, unzip it to a webserver, point Firefox at it, wait for load to complete, then select File / Work Offline and try to File / Save Page As - this should reproduce the bug.
(Reporter)

Comment 3

9 years ago
Created attachment 351769 [details]
test case - block 1 of 11
(Reporter)

Comment 4

9 years ago
Created attachment 351771 [details]
test case - block 2 of 11
(Reporter)

Comment 5

9 years ago
Created attachment 351772 [details]
test case - block 3 of 11
(Reporter)

Comment 6

9 years ago
Created attachment 351773 [details]
test case - block 4 of 11
(Reporter)

Comment 7

9 years ago
Created attachment 351774 [details]
test case - block 5 of 11
(Reporter)

Comment 8

9 years ago
Created attachment 351775 [details]
test case - block 6 of 11
(Reporter)

Comment 9

9 years ago
Created attachment 351776 [details]
test case - block 7 of 11
(Reporter)

Comment 10

9 years ago
Created attachment 351777 [details]
test case - block 8 of 11
(Reporter)

Comment 11

9 years ago
Created attachment 351778 [details]
test case - block 9 of 11
(Reporter)

Comment 12

9 years ago
Created attachment 351779 [details]
test case - block 10 of 11
(Reporter)

Comment 13

9 years ago
Created attachment 351780 [details]
test case - block 11 of 11

Comment 14

8 years ago
This could be associated with https://bugzilla.mozilla.org/show_bug.cgi?id=530288
Reporter, please retest with Firefox 3.6.12 or later in a fresh profile (http://support.mozilla.com/kb/Managing+profiles). Also update your plugins (flash, adobe reader, java, quicktime, silverlight, etc.) Go to the developer's website and download the latest version from there. If you no longer see this issue, please close this bug as RESOLVED, WORKSFORME. If you do see the bug, please post a comment.
Whiteboard: [CLOSEME 2010-12-01]
(Reporter)

Comment 16

7 years ago
I no longer have access to the Windows XP machine I was using when I reported the bug.  However, I confirmed that Firefox 3.6.6 under Mac OS X works correctly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.