Navigator home checkbox pref needs to be saved

VERIFIED FIXED in M18

Status

SeaMonkey
Preferences
P3
normal
VERIFIED FIXED
18 years ago
7 years ago

People

(Reporter: Alek Jeziorek, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FIX IN HAND])

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
-start browser
-Edit|Preferences 
-display is incorrect
Linux comm. 2000-07-28-08- ***M18***
(Reporter)

Updated

18 years ago
Keywords: smoketest

Comment 1

18 years ago
This is on Trunk.  Adding nsbeta3 keyword.  Alek, what is wrong about the 
display?
Keywords: smoketest → nsbeta3

Comment 2

18 years ago
please expand on "display is incorrect"
(Reporter)

Comment 3

18 years ago
the list of preference categories in the left part of the window is blank and it 
is missing the history and location bar history under the Navigator preferences
(Reporter)

Comment 4

18 years ago
i get an XML error now when attempting to look at the navigator prefs:
XML Parsing Error: Unidentified entity
line number 81, column 23
value="&alwaysCheckWhenDropHome.label;"

using build 2000-08-08-08-M18

Comment 5

18 years ago
nav triage team:
nsbeta3+, regression, dogfood keyword
Keywords: dogfood, regression
Whiteboard: [nsbeta3+]
clarifying summary. ben, you or...?
Assignee: matt → ben
Summary: Preferences display is not displayed correctly → Navigator prefs panel not displayed

Comment 7

18 years ago
Putting on [dogfood+] radar.  This is affecting daily testing!!
Whiteboard: [nsbeta3+] → [dogfood+][nsbeta3+]
->all. confirmed on winnt, mac and linux.
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 9

18 years ago
i think i know what the problem is (can you say 'element array'?)
Assignee: ben → BlakeR1234
(Assignee)

Comment 10

18 years ago
I'm pretty sure ben checked the change to navigator.xul in accidentally while 
fixing bug 45687 (see his checkin), but not the entity changes to 
navigator.dtd, which are causing these problems (alec fixed that).  So fast, 
simple fix is for someone to back out the navigator.xul changes for now (but I 
think i have the right fix, testing...)
Status: NEW → ASSIGNED

Comment 11

18 years ago
Created attachment 12558 [details] [diff] [review]
[patch] now make it save this pref too

Comment 12

18 years ago
Attached a patch which adds this pref to the array of elements to be saved to 
prefs.js.
Keywords: patch, review
(Assignee)

Comment 13

18 years ago
Thanks for attaching it jag. r=me (we just worked on it, but I was a bit far 
from home to be able to attach the patch myself)  So now if anyone could check 
this in...
Keywords: review
(Reporter)

Comment 14

18 years ago
cc:twalker

Comment 15

18 years ago
Ben, PDT thinks you should own checking this in.  Dogfood bugs are high 
priority.  Thanks,  Steve
Assignee: BlakeR1234 → ben
Status: ASSIGNED → NEW
(Assignee)

Comment 16

18 years ago
er.  This bug isn't dogfood+ or nsbeta3+ anymore. the navigator prefs display 
fine.  I was just gonna use this to checkin the simple fix, rather than filing 
a separate bug (I'll check it in tonight).

(It's also courteous to talk to the owner of a bug before reassigning it to 
someone else)
Assignee: ben → BlakeR1234
Keywords: dogfood, nsbeta3, patch, regression
Summary: Navigator prefs panel not displayed → Navigator home checkbox pref needs to be saved
Whiteboard: [dogfood+][nsbeta3+]
I'm uncertain that this is a bug.....There is another choice in the preferences 
window that brings up the history information in question.  2000-08-14-04-M18

Comment 18

18 years ago
Putting on nsbeta3 nominee radar.
Keywords: nsbeta3
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [FIX IN HAND]
Target Milestone: --- → M18
(Assignee)

Comment 19

18 years ago
Created attachment 13447 [details] [diff] [review]
patch (something wrong with the other)
(Assignee)

Comment 21

18 years ago
Thanks, guys. Sorry to have kept buggin' ya. Fix checked in...
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
marking verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.