Lost bookmarks and back & forward button navigation when upgraded to 3.0.4

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: greg_savino, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

The browser is basically useless if you can't bookmark, go back or forwards. It was fine until I allowed the upgrade to 3.0.4 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Sound like your places.sqlite file is locked.

Close Firefox and check if you have any Firefox process hang in memory
Check in your profile folder if you have any .corrupt file
Test in Safe Mode: http://support.mozilla.com/kb/Safe+Mode
(Reporter)

Comment 2

10 years ago
Thanks but...
no memory hang. i have forced quit & also restarted numerous times.
no .corrupt file that I could recognize
and launching in safe mode with the various check  boxes marked & unmarked didn't work either.

A curious fact...
Safari is not launching since it's latest upgrade. I am using OSX 10.4.11
I decided to just use Camino and abandon these 2 browsers altogether
From which version did you upgraded ?
Can you force a check of your file system ?
(Reporter)

Comment 4

10 years ago
Not exactly sure what was the previous version. I always let Firefox upgrade automatically so I'm confident it was the immediate release.
I don't know what/how "force checking a the file system" is/means.
BTW: Camino works great.
please try creating a new profile, your old profile for some reason appear locked or corrupt... if your places.sqlite is not too big you can also send it to me by mail to take a look at it.
(In reply to comment #5)
> please try creating a new profile, your old profile for some reason appear
> locked or corrupt... if your places.sqlite is not too big you can also send it
> to me by mail to take a look at it.

i clearly mean places.sqlite from your old profile.
(Reporter)

Comment 7

10 years ago
Marco,
Thanks. I simply trashed the folder Library/Application Support/Firefox.
When I launched FF, it recreated the folder and the buttons are working fine. I did however loose my bookmarks, but at least the app works. BTW, I do like Camino.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.