two-level pull-down menu for "Window", showing tabs

RESOLVED DUPLICATE of bug 433954

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 433954
10 years ago
10 years ago

People

(Reporter: rdm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

I run lots of windows, each of which may contain lots of tabs.  I use WindowShade X to hide all but the drag bars of windows I'm not currently viewing.  Although this all works pretty well, I have a problem locating specific tabs, by content.

It strikes me that the "Window" menu item could have a two-level pulldown, with the second level listing any tabs that aren't currently selected.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
What do you mean by "Window" menu item? I am not aware of that on Firefox.
(Reporter)

Comment 2

10 years ago
On Mac OS X, Firefox has a "Window" pull-down in the application's menu bar.  It contains Minimize, Zoom, and a list of window titles.  It's this latter list that I'm suggesting extending with sub-menus.

In other news, the "Window" pull-down could also use a few more items.  See Leopard's Terminal.app for ideas...
i think that is part of the Mac OS. See the screenshots on http://support.mozilla.com/en-US/kb/Installing+Firefox+on+Mac for what I mean.
(Reporter)

Comment 4

10 years ago
The menu items are presented by the OS, but they are specified by the app.  Could this bug be handled by someone who works on Mac-related UI issues?

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433954
You need to log in before you can comment on or make changes to this bug.