Success message is missing file status when uploading additional files for a version.

VERIFIED FIXED in 3.5

Status

--
major
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: stephend, Assigned: cesar)

Tracking

unspecified

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
Summary: Success message is missing file status when uploading additional files for a version.

Steps to Reproduce:

1. Load https://addons.mozilla.org/en-US/developers/versions/edit/45973 (Justin, I've made you an Owner.)
2. Click "Add New File"
3. Choose "Archive.xpi" and click "Upload File"

Actual Results:

"Your new file has been added to version 2.0 and is currently marked as ."
(Reporter)

Comment 1

10 years ago
As a side note, I can't log in to http://remora-3.5.php5stage.mozilla.com/en-US/firefox/ any longer :-(.
(Reporter)

Comment 2

10 years ago
Created attachment 351730 [details]
Archive.xpi
(Reporter)

Comment 3

10 years ago
Created attachment 351731 [details]
Screenshot
(Reporter)

Comment 4

10 years ago
Created attachment 352265 [details]
Another screenshot; this time with multiple "Add to Firefox" buttons

fligtar, would you mind taking a look whenever you have a free moment?
(Assignee)

Comment 5

10 years ago
Created attachment 352284 [details] [diff] [review]
catch sandox-only addons

These seems to be caused when you upload a new version of a sandbox only addon, one that has not been nominated. An if-else if statement didn't catch sandox only addons.

Addons that have been marked disabled seem to throw the right message. So I think we're fine for all the different statuses an addon could be under when uploaded. But I could be wrong.
Assignee: nobody → cdolivei.bugzilla
Status: NEW → ASSIGNED
Attachment #352284 - Flags: review?(fligtar)

Updated

10 years ago
Attachment #352284 - Flags: review?(fligtar) → review+
(Reporter)

Updated

10 years ago
Whiteboard: needs-checkin
(Assignee)

Comment 6

10 years ago
Thanks for the review Justin. My development box is not on the network, so I can't check this in. If anyone can for me, that will be appreciated. I think this has to be checked in for both 3.5 and trunk.
(Assignee)

Comment 7

10 years ago
A sufficiently lengthy extension cable solved my network issue. In both trunk and 3.5. r22761
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: push-needed
Resolution: --- → FIXED
Whiteboard: needs-checkin
(In reply to comment #7)
> A sufficiently lengthy extension cable solved my network issue. In both trunk
> and 3.5. r22761

Thanks, No need to change the 3.5 branch.
(Reporter)

Updated

10 years ago
Duplicate of this bug: 458457

Updated

10 years ago
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.