Mouse Gestures Redox (addons #39) [@ mgMouseService.so@0x2ddd]

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
--
critical
RESOLVED INVALID
10 years ago
7 months ago

People

(Reporter: timeless, Assigned: Jochen)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
Signature	mgMouseService.so@0x2ddd
UUID	34623a32-2aa7-4512-b7b3-7cfde2081204
Time	2008-12-04 16:07:34-08
Uptime	39
Last Crash	42 seconds before submission
Product	Firefox
Version	3.2a1pre
Build ID	20081204021237
Branch	1.9.2
OS	Linux
OS Version	0.0.0 Linux 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux
CPU	x86
CPU Info	GenuineIntel family 10 model 22 stepping 1
Crash Reason	SIGSEGV
Crash Address	0xb376fddd
Comments	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	mgMouseService.so 	mgMouseService.so@0x2ddd 	
1 	libgdk-x11-2.0.so.0.1400.4 	libgdk-x11-2.0.so.0.1400.4@0x47165 	
2 	libgdk-x11-2.0.so.0.1400.4 	libgdk-x11-2.0.so.0.1400.4@0x490b2 	
3 	libgdk-x11-2.0.so.0.1400.4 	libgdk-x11-2.0.so.0.1400.4@0x494de 	
4 	libglib-2.0.so.0.1800.2 	libglib-2.0.so.0.1800.2@0x396f7 	
5 	libglib-2.0.so.0.1800.2 	libglib-2.0.so.0.1800.2@0x3cda2 	
6 	libglib-2.0.so.0.1800.2 	libglib-2.0.so.0.1800.2@0x3cf60 	
7 	libxul.so 	nsAppShell::ProcessNextNativeEvent 	widget/src/gtk2/nsAppShell.cpp:144
8 	libxul.so 	nsBaseAppShell::DoProcessNextNativeEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:151
9 	libxul.so 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:278
10 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:497
11 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:227
12 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
13 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:192
14 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3268
15 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:156
16 	libc-2.8.90.so 	libc-2.8.90.so@0x16684
(Assignee)

Comment 1

10 years ago
I'm not able to reproduce the crash.
(Ubuntu 8.10, 2.6.27-9-generic)

BTW:
There is no MozGest version compatible with Fx 3.2a1pre!
...at least I can't remember that I've released such a version.
(Reporter)

Comment 2

10 years ago
yeah, well... please see the reports it's clear that this library (which i take it you're confirming is probably yours) is hurting someone.

actually, it looks like precisely one person:
Linux 0.0.0 Linux 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux

can crash reporter send people messages? i'd really love to send this guy one :(
If the user submitted an email, you could file a server ops bug to ask aravind to query the db directly for his email. Socorro doesn't have any functionality to do anything with email addresses as it stands.
(Assignee)

Comment 4

10 years ago
One question:
What's the meaning of "Uptime 39"? Minutes, seconds, milliseconds?
And, yes "mgMouseService.so" is my library.

I still can't reproduce the crash though.
Uptime is seconds since the program started to the time it crashed.

Comment 6

10 years ago
i recently had a crash with this stacktrace, so I think this may be me. What do you need?
(Reporter)

Comment 7

10 years ago
well, a couple of things would help.

1. you could load about:crashes and figure out which one is yours so that i know which one.
2. install -dbg / -debuginfo / symbols for at least libgdk-x11 libgdk-x11, ideally for everything loaded in gecko.

w/ a stack trace, it should be possible to try to figure out which functions were being called.

jochen: do you have debuginfo for your extension?

Comment 8

10 years ago
here's one I just got: http://crash-stats.mozilla.com/report/index/c747d524-7b1f-4132-9c04-697972081209

also: I'm not quite sure what you want me to install. care to explain what you want?
(Assignee)

Comment 9

10 years ago
Ok, I can reproduce the crash.
http://crash-stats.mozilla.com/report/index/a8d93bd6-db8c-4ce6-9d59-123f52081210

There is no reliable way to reproduce the crash, but closing a tab will sooner
or later reproduce the crash after clicking on content.

In MozGest 2.0.3 mgMouseService.so is calling GDK_IS_WINDOW(xyz) and it's not
sure xyz still exists or is currently destroyed. 

https://addons.mozilla.org/en-US/firefox/addons/versions/39#version-2.1.0pre2
or
http://www.mousegestures.org/download/release/2.1.X/mozgest_2_1_0pre2.xpi
should work, because the crashing code was removed several weeks ago.
Both links should serve identical builds.

I wish there would be a simple (and frozen) way to get the window handle of 
the current content...

@Shayne Jewers:
Can you please download the above mentioned build and test it? Thanks!
Of course you have to bump compatibility to Fx 3.2a1pre... ;)
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 10

10 years ago
http://library.gnome.org/devel/gtk/unstable/GtkWidget.html
  "delete-event"                                   : Run Last
  "destroy-event"                                  : Run Last

try listening for these?
(Assignee)

Comment 11

10 years ago
(In reply to comment #10)
> http://library.gnome.org/devel/gtk/unstable/GtkWidget.html
>   "delete-event"                                   : Run Last
>   "destroy-event"                                  : Run Last
> 
> try listening for these?

Well, to be honest, I wasn't aware of that.

The crashing code was removed weeks ago, because it wasn't needed.
It wasn't removed because it was crashing.

Is there a "lean and mean" way to get the window handle of the currently displayed content window? Maybe via "nsIWindowWatcher"?
(Reporter)

Comment 12

10 years ago
fwiw, i had to ask a coworker, and i know for a fact that our (corporate) codebase crashes because of stale pointers such as these, so even though we know of it, it doesn't seem to mean we properly use it.
(Assignee)

Comment 13

10 years ago
What a mess!

From my point of view the bug is already fixed because the upcoming version
of MozGest comes without the crashing code.

It's just a matter of time for review (AMO) though... 
The main problem for an update (AMO) is that mgMouseService is closed source...

Comment 14

10 years ago
I haven't had crashing in a while, so it looks like this is fixed.
Crash Signature: [@ mgMouseService.so@0x2ddd]

Comment 15

4 years ago
Portable Nightly 37.0a1 (2014-12-21) Have been using the Portable Nightly the past few days and trying to get mouse gestures to work, between All-In-One Gestures and FireGestures.  Have had some little successes.  I think the gestures interface is very important.  I have gotten used to using it.  No crashes at all since I've been using the Portable Nightly.

Comment 16

7 months ago
This is about a legacy add-on which is no longer compatible with Firefox 57, so closing.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.