Last Comment Bug 468303 - When JS precedes CSS, the page is not rendered properly
: When JS precedes CSS, the page is not rendered properly
Status: RESOLVED INCOMPLETE
[CLOSEME 2010-11-01]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 3.0 Branch
: x86 Windows Vista
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://extjs.com/forum/showthread.php...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 22:28 PST by staskorz
Modified: 2010-11-01 22:45 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description staskorz 2008-12-06 22:28:54 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 FirePHP/0.2.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 FirePHP/0.2.1

The problem is describe in details at the following URL:

http://extjs.com/forum/showthread.php?t=53960

The issue does not occur in IE7 or Opera 9.62, but only in FF (tested with FF 3.0.4). The only workaround is to place the CSS before JS.

Reproducible: Always

Steps to Reproduce:
1. In the HTML file, put the <script type="text/javascript" src="script.js"></script> before the <link rel="stylesheet" type="text/css" href="style.css">
2.
3.
Actual Results:  
The page is not rendered properly - some elements are missing. In the current example, the right border of the GridPanel is missing.

Expected Results:  
The page should be rendered properly.
Comment 1 Tyler Downer [:Tyler] 2010-10-06 11:38:06 PDT
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Comment 2 Tyler Downer [:Tyler] 2010-11-01 22:45:59 PDT
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.

Note You need to log in before you can comment on or make changes to this bug.