Closed Bug 468363 Opened 12 years ago Closed 3 years ago

Clicking on URL in history drop-down does not autocomplete URL

Categories

(SeaMonkey :: Location Bar, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0b1

People

(Reporter: mcsmurf, Assigned: mcsmurf)

References

Details

(Keywords: verified1.9.1)

Attachments

(1 file)

To reproduce:
1. Go to a URL which is handled by a 3rd party application. I used a MP3 playlist, for example http://www.di.fm/mp3/house.pls; I saved that this mime-type always gets opened with Winamp
2. Type "di.f" in the URL bar so that the URL appears again
3. Click on it

Results:
It does not open the URL, but opens "di.f" instead which results in a Page Load Error.
That URL doesn't go into history when I try...
I think I sometimes saw something like that when not clicking on the URL itself but the title, but I'm not 100% sure how I triggered that.
Well, I imported an old history that did contain that URL into Places, and it autocompleted for me and I clicked it but it still loaded fine.
(In reply to comment #1)
> That URL doesn't go into history when I try...
Places has its own nsIDownloadHistory implementation which does record downloads but I don't know if or how it exposes that information.
Ok, it turned out that the 3rd party application part is not related. I had the problem with another page with "di.f" in the URL, for example http://forums.di.fm/funky-house/short-bus-kids-short-bus-of-funk-130671/. When I enter "di" in the URL bar clicking on URLs works just fine (URL gets autocompleted). But when I enter "di." and then click on any URL in the history drop down the URL does not get autocompleted anymore. So maybe it has to do with the "." in the text I entered into URL bar.
Summary: Clicking on URL in history drop-down which is handled by a 3rd party application does not autocomplete URL → Clicking on URL in history drop-down does not autocomplete URL
My experience has been that clicking on a URL searches the web for the part I typed. For instance if I am looking for http://www.yavsoft.com/japanolle/ and I type "jap" into the location bar and click on the appropriate result in the drop down list I am taken to a Google search on "jap". It works correctly if I select it using the down arrow and enter keys on the keyboard but on a laptop it's easier to just swipe and then tap on the touchpad with my thumb rather than having to move my right hand off home row.
I think I now know what is needed to reproduce this bug: You need to click on the URL in the dropdown while it is still searching for other results (at least here you can clearly notice when it's still searching as the UI is quite sluggish, probably because of my large history).
The problem seems to be in line 858 function onResultClick(), autocomplete.xml. When you set a breakpoint there and a watch on this.noMatch, this.noMatch is set to true. Note that if you wait a second or so and then evaluate this.noMatch in the Venkman commandline, this.noMatch is false. So due to this.noMatch being true, it does not replace the text in the urlbar with the URL itself. And due to that it tries to load what you have typed in.
Attached patch PatchSplinter Review
This should do it. I don't see why we need to check for this.noMatch here as when there is no match you also cannot click on any entry. The search engine entry in the URL bar autocomplete popup gets handled by the "if (val)" block, LDAP error messages are handled by the "if (this.getSessionStatusAt(this.resultsPopup.selectedIndex) ..." code inside that "else if" block. Other special cases are not known to me.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #372584 - Flags: review?(neil)
Comment on attachment 372584 [details] [diff] [review]
Patch

Seems reasonable.
Attachment #372584 - Flags: review?(neil) → review+
Pushed to mozilla-central, http://hg.mozilla.org/mozilla-central/rev/fdf8eee601f8
Pushed to 1.9.1, http://hg.mozilla.org/releases/mozilla-1.9.1/rev/b86179f32db9
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0b1
verified FIXED on builds using instructions from comment #6:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090504 Minefield/3.6a1pre ID:20090504044532

and

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090504 Shiretoko/3.5b5pre ID:20090504044259
Status: RESOLVED → VERIFIED
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/96e297d08b3f
Clicking on URL in autocomplete drop-down while search is running does not autocomplete URL, r=Neil, SeaMonkey/Thunderbird only
Status: VERIFIED → RESOLVED
Closed: 12 years ago3 years ago
You need to log in before you can comment on or make changes to this bug.