PNG transparency problem

VERIFIED DUPLICATE of bug 460629

Status

()

Core
GFX: Color Management
--
major
VERIFIED DUPLICATE of bug 460629
9 years ago
9 years ago

People

(Reporter: Luka, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; sl; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; sl; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

I have a page with lots of png images and some gif's. There is a problem with color rendering in png images. The background around the text should render from white to transparent (the background is gray, so it should fade to gray). Insteat it fades from white to brownish. There are several banners with links to different sections on the page. I have used transparent png's for background and gif for the picture and text. The gifs have slight border that should be the same color than the background pngs, but it is not. Tha can be seen in many areas on the page. That is not seen in FF3.0 and lower, IE7, Opera, Chrome and Safari.

Reproducible: Always

Steps to Reproduce:
1. Load my webpage (http://www.bubi.si/nova)
Actual Results:  
The background fading is from white to brownish. There is a border around several pictures in the banners.

Expected Results:  
The background on the page should be consistent and should fade from white on the center to the gray on the border. The colors in the banner should be uniform.
This is what I see with the latest test build on Windows XP: http://img178.imageshack.us/img178/4130/testzb4.png
I get the same result as Ria, if you get a different result, can you try to set gfx.color_management.mode to 0 (from 2) in about:config ?
(Reporter)

Comment 3

9 years ago
@Matthias Versen: TNX, that solved the issue. But what does that config. do? Are my png's corrupted and need this fix? Because I need the page to work with default settings. Is this MS Vista's issue?
Without this I see: http://img176.imageshack.us/img176/3949/screenvh4.jpg
Probably a problem with the profile data in the image if comment 2 fixed it for you. It works for me using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081104 Minefield/3.1b2pre (Vista) with gfx.color_management.mode set to 2.
We implemented color Management with FF3.1.
(read http://en.wikipedia.org/wiki/Color_management if you want to know more).

It could be an image problem (wrong color correction informatrion in the image) but it works for me (I'm using Seamonkey on vista) and Natch and that means that your Color Profile for your Monitor is wrong.
Which Monitor Do you use ?
Can you try to get an updated ICC profile for your Monitor ?
(Reporter)

Comment 6

9 years ago
I am using laptop Lenovo R61 with NVidia Quadro NVS 140M. I have upgraded drivers and ICM file (that should upgrade ICC on Vista). But if I set color_management to 2 I get the same resaults as before.
However it looks this is not a bug in Firefox, at least nobody confirmed it. Thanks for all your help, I really apreciate it. I guess we can close this one not to mess with the more important stuf. I will try to get help on the forums.
Regards, Luka
Component: General → ImageLib
Product: Firefox → Core
QA Contact: general → imagelib
Component: ImageLib → GFX: Color Management
QA Contact: imagelib → color-management
Luka - could you try things out with the latest nightly builds at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
?

Over the weekend I landed 2 patches that detect and disable bad profiles, bug 460629 and bug 460520. I'm curious to see if they fix your issue.

If they do, then it would be good to confirm that it's also fixed for 3.1 (I cross-landed that code on monday).
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-1.9.1/

Thanks
(Reporter)

Comment 8

9 years ago
I have tested my page using latest nightly builds and latest mozilla 1.9.1. The color deviation is no longer present. I can confirm that in my case the problem is fixed. Thanks for those patches.
awesome. I'm pretty sure it was bug 460629 that did the trick here, so resolving this bug as a duplicate of that.

Thanks for testing those builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460629
Please note that your display color profile is wrong and Gecko only ignores it now.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

9 years ago
Yes, I understand that. But I use default settings on this laptop and have all the updates installed. i have updated my ICC to the latest version. Since this is a standard laptop with no modification it is very likely possible there are a lot of users with wrong color profile settings. This might also true for a lot of other users on different computers. I am interested in finding a solution and fix the problem with color profile for my display, but frankly do not kno how (yet).
But from the John Doe's (who finds my page by search query and has wrong color profile for his display) perspective: he will just think that my page is corupted and not came back again. He will probably not use different browser to test it, or even tried to update his ICC settings. And once he will have problems on other pages, he will eventualy start using alternative browsers, that ignore those settings. Therefor I think it is good to have this fix. The users with correct color profile will benefit from correctly displayed colors and those of us with wrong settings will, well, just see the web as we did it until now.
You need to log in before you can comment on or make changes to this bug.