Find Bar should stop with audio/visual warning at end of Finds before continuing

RESOLVED DUPLICATE of bug 266338

Status

()

Toolkit
Find Toolbar
--
enhancement
RESOLVED DUPLICATE of bug 266338
10 years ago
10 years ago

People

(Reporter: David McRitchie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 (.NET CLR 3.5.30729)

There should be a beep and message when F3 (repeat Find) is used and there are not more hits in the current direction, after that warning the next use of F3 should then proceed to the next find from the top as it does now without warning.  Same applies for Next/Previous buttons in the direction of use.

As it is the message on the Find Bar comes without warning after you have advanced to the top of page to continue Find process.  Without an auditory warning you can simply go around in circles with Find, and I think everyone has experience with that.

The best that I can do as a workaround,  if I notice that I've restarted at the top is to use  Shift+F3 as a one time reversal which takes me back.  The next F3 would continue in prescribed direction (normally down).

Reproducible: Always
Component: Toolbars → Find Toolbar
Product: Firefox → Toolkit
QA Contact: toolbars → fast.find

Comment 1

10 years ago
See bug 281533 for adding a sound.

I like the way TextWrangler's Find wraps: it proceeds immediately, but a transparent thing appears in the middle of the window for a second, making it clear that it has wrapped.
Status: UNCONFIRMED → NEW
Depends on: 281533
Ever confirmed: true

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
No longer depends on: 281533
Resolution: --- → DUPLICATE
Duplicate of bug: 266338
You need to log in before you can comment on or make changes to this bug.