bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Failed to connect to internet using Firefox. Internet Explorer Works. Older Firefox versions work.

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Scott E. Dahl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18) Gecko/20081029 Firefox/2.0.0.18
Build Identifier: Windows Firefox Latest Version 3.04

I downloaded the latest build of Firefox version 3.04.  I found that the internal IBM intranet pages work fine, but when I try to go outside of the company's firewall, I get a "Failed to Connect" message.  Internet Explorer works fine.  I downloaded an older version of Firefox version 2.0.0.18 and this works fine.  I tried to download version 3.04 again and it still doesn't work so it must be the new build.  I am using windows XP with an IBM Thinkpad T42p.  The problem occured right after I upgraded to version 3.04.  Version 3.03 worked fine for me.

Reproducible: Always

Steps to Reproduce:
1.  Install latest Firefox build version 3.04 from firefox.com website.
2.  Type yahoo.com or aol.com in url bar.
3.  See error message "Failed to connect".
Actual Results:  
internet access outside of IBMs intranet firewall does not work with version 3.04, but does work with older versions.

Expected Results:  
I expected the web page to load correctly, but the new Firefox could not load the page.  I had to use internet explorer instead to load the page.
>I tried to download version 3.04 again and it still doesn't work
>so it must be the new build.

You logic isn't right :-)
From our experience this is in 99,9999% a Firewall issue. I mean in this case a personal Firewall on your system and not a Firewall on the LAN border.

Please download 3.0.4, open your personal Firewall configuration on your system and remove the Firefox entry. After that start 3.0.4 and let the Firewall ask again for the Firefox permissions.

I would resolve this as worksforme/invalid but your a in a special enviroment which could be affected by proxy settings.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.