Closed Bug 468743 Opened 13 years ago Closed 13 years ago

Crash on exit [@ libgtk-x11-2.0.so.0.1200.9@0x2735fc - libflashplayer.so@0x38eba]

Categories

(Core :: Plug-ins, defect)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 485125

People

(Reporter: u279076, Assigned: mmelanso)

References

()

Details

(Keywords: crash)

Crash Data

BUILD: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20081209 Minefield/3.2a1pre
OS: Ubuntu 8.04 32-bit i686

Whenever I exit, Minefield crashes.  This happens on a new profile and in safe mode.  The crash report looks like it is hitting libflashplayer before the crash.  Not sure whether that is coincidental or a factor in this crash.  I am not loading any flash content.  In fact, I can close Minefield after the first run and I will see the crash.

I looked around and found a couple other "crash on exit" bugs, but not where libgtk was the crashpoint.

I have included a link above to one of my crash reports.
bp-ffbd97d7-d938-42df-b89d-4d6de2081209
Have you tried exiting in safe mode? Or a new profile.
(In reply to comment #1)
> Have you tried exiting in safe mode? Or a new profile.
(In reply to comment #0)
> This happens on a new profile and in safe mode.

Well, obviously to check if it's the Flash plugin's fault just disable it via the add-ons manager, exit, and see if it crashes. (also try loading Firefox up with it disabled and try exiting again, just to be sure) If it doesn't then it's Flash's doing in some way, which it probably is.

What Flash player version? It's not saying in there. Get v10 if you haven't:
http://get.adobe.com/flashplayer/
Severity: normal → critical
Keywords: crash
Summary: Crash on Exit @libgtk-x11-2.0.so.0.1200.9@0x2735fc → Crash on exit [@ libgtk-x11-2.0.so.0.1200.9@0x2735fc ]
Signature	libgtk-x11-2.0.so.0.1200.9@0x2735fc
UUID	ffbd97d7-d938-42df-b89d-4d6de2081209
Time	2008-12-09 15:56:14-08
Uptime	4388
Product	Firefox
Version	3.2a1pre
Build ID	20081209061858
Branch	1.9.2
OS	Linux
OS Version	0.0.0 Linux 2.6.24-22-generic #1 SMP Mon Nov 24 18:32:42 UTC 2008 i686 GNU/Linux
CPU	x86
CPU Info	GenuineIntel family 10 model 15 stepping 11
Crash Reason	SIGSEGV
Crash Address	0xb6fa35fc
Comments	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libgtk-x11-2.0.so.0.1200.9 	libgtk-x11-2.0.so.0.1200.9@0x2735fc 	
1 	libflashplayer.so 	libflashplayer.so@0x38eba 	
2 	libflashplayer.so 	libflashplayer.so@0x2e417 	
3 	libflashplayer.so 	libflashplayer.so@0x27260 	
4 	libflashplayer.so 	libflashplayer.so@0x2ba16 	
5 	libxul.so 	nsNPAPIPluginInstance::Stop 	modules/plugin/base/src/nsNPAPIPluginInstance.cpp:880
6 	libxul.so 	DoStopPlugin 	layout/generic/nsObjectFrame.cpp:1962
7 	libxul.so 	nsStopPluginRunnable::Run 	layout/generic/nsObjectFrame.cpp:2025
8 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:510
9 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:227
10 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
11 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:192
12 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3283
13 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:156
14 	libc-2.7.so 	libc-2.7.so@0x1644f 	

libflashplayer.so 		745026564F2B12E0E3B2715D145A0F690 	libflashplayer.so
Assignee: nobody → msintov
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Summary: Crash on exit [@ libgtk-x11-2.0.so.0.1200.9@0x2735fc ] → Crash on exit [@ libgtk-x11-2.0.so.0.1200.9@0x2735fc - libflashplayer.so@0x38eba]
Assignee: msintov → mmelanso
Is this related or should I report another bug? 
bp-7778cd27-fd7c-4be3-9e2d-f2dfc2090127
The top frame is libflashplayer in mine instead of libgtk, and I am using 3.1b2 instead of 3.2.
(In reply to comment #4)
> Is this related or should I report another bug? 
> bp-7778cd27-fd7c-4be3-9e2d-f2dfc2090127

File another bug. (update to Flash 10 first, if you haven't already)
I filed bug 475573, hopefully it's ok.
Forward duping to the fixed bug 485125.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 485125
Crash Signature: [@ libgtk-x11-2.0.so.0.1200.9@0x2735fc - libflashplayer.so@0x38eba]
You need to log in before you can comment on or make changes to this bug.