Crash [@ nsMediaStream::Cancel] with bogus protocol

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 1 bug, {crash, testcase})

Trunk
x86
Mac OS X
crash, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 352257 [details]
testcase (crashes Firefox when loaded)
I can't reproduce this any longer.  Tracing the URI load, we pass a valid nsIURI for "nosuchprotocol:" to NS_NewChannel and it returns NS_ERROR_UNKNOWN_PROTOCOL, causing us to immediately return an error from Load().  I suspect it was fixed by the patch from bug 464158.

Jesse, can you please confirm that it no longer crashes for you?
(Reporter)

Comment 2

10 years ago
No longer crashes for me.  Also, doesn't toss up an unknown-protocol dialog, which makes me happy and makes this crashtestable.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

10 years ago
Flags: in-testsuite+
(Assignee)

Updated

8 years ago
Crash Signature: [@ nsMediaStream::Cancel]
You need to log in before you can comment on or make changes to this bug.