Camino 1.6.5 becomes unresponsive after several hours of use.

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
10 years ago
9 years ago

People

(Reporter: hotvoodoowitch, Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.18) Gecko/20081112 Camino/1.6.5 (like Firefox/2.0.0.18)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.18) Gecko/20081112 Camino/1.6.5 (like Firefox/2.0.0.18)

Multiple tabs open = non-responsive Camino within a few hours, necessitating a quit and reopen. Typing is like pulling through a vat of molasses, regardless of how long it has been open; it's making Windows look good. I DON'T HAVE TIME FOR THIS.
In addition, AOL isn't responding properly with this build. Attempting to open a specific folder, e.g., "old mail," just causes the same page to reload (sometimes, hitting the "refresh" button helps).
Finally, there are times when hitting the refresh button results in the opening of multiple tabs. Gone are the days when tabs could be closed from a different window--I now have to open the tab I want to delete (and which I never wanted to open the first place) in order to get rid of it. Try doing that for multiple tabs in a slow browser.
I've used Camino for years and used to love it. However, it just seems like one big memory leak of late. And when are we going to be able to view PDF documents without having to download them?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
You're kidding, right? Should I provide my AOL password?



Well, I'm not using any Camino add-ons/enhancers, if that'll help. And when Camino hangs, my entire system grinds to a halt. It's a browser--how much of my system's resources is it supposed to hog?

Comment 1

10 years ago
If I'm understanding correctly this is 4 unrelated bug reports and a (duplicate) feature request. We can't practically debug or track a bunch of unrelated things in the same report, so I'm going to make this purely about eventual slowdowns and ask that you file individual new bug reports for the other problems. (Slow typing is a known issue for pre-2.0 versions with pages that do animation, so no need to file that again if you are on pages that have animation or Flash when you see that.)


Some questions so we have a better idea of what the issue is specifically:
1) First, what version of OS X do you have, and what hardware?
2) Define "non-responsive": Does it show the spinner cursor indefinitely and require a force-quit? Does it show the spinning cursor briefly, then go back to the normal cursor? Is it just somewhat slow to respond?
3) Does closing all the pages instead of quitting work just as well?
4) Does it matter what pages you visit?
Summary: S L O W (is that "key" enough?). I can't even type in real time. In addition, AOL is exhibiting quirks that aren't evident with Safari or, for that matter, with 1.5.1. → Camino becomes unresponsive after several hours of use.
Version: unspecified → 1.8 Branch
Summary: Camino becomes unresponsive after several hours of use. → Camino 1.6.5 becomes unresponsive after several hours of use.

Comment 2

10 years ago
(In reply to comment #0)
> And when are we going to be able to view PDF documents
> without having to download them?

Since approximately 2003, using this:

http://www.macupdate.com/info.php/id/9542/

Comment 3

9 years ago
Closing based on lack of response. If you can provide the answers to the questions in comment 1, feel free to re-open this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.