Preference window incorrectly shows default font

RESOLVED FIXED in Thunderbird 3.0b2

Status

defect
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: prodigiouspenguin, Assigned: yuki)

Tracking

unspecified
Thunderbird 3.0b2
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4
Build Identifier: Ubuntu 8.10

The preference window does not show the user-chosen default font; only "variable width".  However, the user-chosen font is used when composing a new message.

Reproducible: Always

Steps to Reproduce:
1. Change the default HTML font from "Variable width" to something else
2. Close the preferences window
3. Open the preferences window
Actual Results:  
"Variable width" is displayed as the chosen font

Expected Results:  
Another font "Arial", "Times New Roman", etc should be shown as the chosen font

Comment 1

10 years ago
this is pretty broken...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3?
Target Milestone: --- → Thunderbird 3.0b2
(Assignee)

Comment 2

10 years ago
I also saw same problem on Thunderbird 2.0.0.x. On Shredder (trunk), no item is chosen instead of "Variable width".

The problem is caused by processes like following:
1. The preferences dialog is loaded. The menulist only have few built-in items,
   "Variable width", "Fixed width", etc.
2. <preference> tries to choose the menu item for "Arial". But there is no
   <menuitem> for the font. So, <preference> does nothing.
3. <prefpane> fires "paneload" event and gComposePane.init() is called.
   The list of installed fonts are generated by gComposePane.populateFonts().

To fix this bug, we have to generate the list of fonts before <preference>'s choosing.
(Assignee)

Comment 3

10 years ago
Or, choosing menuitem again by populateFonts() can fix it too.
(Assignee)

Comment 4

10 years ago
Attachment #356635 - Flags: superreview?(bienvenu)
Attachment #356635 - Flags: review?(bienvenu)
(Assignee)

Comment 5

10 years ago
Attachment #356636 - Flags: superreview?(bienvenu)
Attachment #356636 - Flags: review?(bienvenu)
Assignee: nobody → piro
Status: NEW → ASSIGNED

Updated

10 years ago
Attachment #356635 - Flags: superreview?(bienvenu)
Attachment #356635 - Flags: superreview+
Attachment #356635 - Flags: review?(bienvenu)
Attachment #356635 - Flags: review+

Comment 6

10 years ago
Comment on attachment 356635 [details] [diff] [review]
Patch for Shredder (ver.1.0)

thx for the patch - I'll land this.

Updated

10 years ago
Attachment #356636 - Flags: superreview?(bienvenu)
Attachment #356636 - Flags: superreview+
Attachment #356636 - Flags: review?(bienvenu)
Attachment #356636 - Flags: review+

Updated

10 years ago
Attachment #356636 - Flags: approval1.8.1.next?

Comment 7

10 years ago
Comment on attachment 356636 [details] [diff] [review]
Patch for Thunderbird 2.0.0.x (ver.1.0)

requesting approval for next 2.0x build - trivial fix. (no guarantee that we'll take this but it doesn't hurt to ask)

Comment 8

10 years ago
fix on trunk for Shredder
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Flags: blocking-thunderbird3?
Comment on attachment 356636 [details] [diff] [review]
Patch for Thunderbird 2.0.0.x (ver.1.0)

We have too few resources to introduce any risk into the branch for patches which are not security or stability problems.  Unfortunately, this doesn't qualify as either of those.  Apologies.
Attachment #356636 - Flags: approval1.8.1.next? → approval1.8.1.next-
You need to log in before you can comment on or make changes to this bug.