Allow sending the password change e-mail when manually adding a user

RESOLVED DUPLICATE of bug 272407

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 272407
10 years ago
8 years ago

People

(Reporter: again, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Bugzilla 3.0.5

In corporate environments it's often the case that access to the Bugzilla installation is restricted and a self-signup is not possible. This leads to the case that one administrator manually adds users. In this case it would be very useful if the "Forgot password e-mail" could be sent out from the edit user page.

This would relieve the administrator from having to choose a good password, note it, send it to the user together with an explanatory message and explain how to change this password.

The best case would be of course if a welcome mail could be automatically sent that describes the purpose of Bugzilla and contains some help. This welcome mail should contain a link where the new user can set the password by himself.

Reproducible: Always
Probably even better than this would be just restricting createaccount.cgi to an admin, because then you could just type in somebody's email address and all of it would be done automatically, without too much additional code on our part.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 272407
You need to log in before you can comment on or make changes to this bug.