Changing the position attribute causes flickering when the element contains scrolled content

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: artur.signell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Changing the position to or from absolute for a DIV which contains scrolled content causes the whole screen to flicker. The content may be for instance a DIV with overflow: auto, containing a larger element. If the scrollable content is scrolled to the top-left when changing the position for the parent element no flickering is visible but if it has been scrolled either to the right or down the whole page will flicker. See the URL for a test case.

Please note that in this small test case it is barely visible but in a more complex web page the flickering is very noticeable and very annoying as it seems that all elements (also the parents to the position: absolute element, all the way up to the body) in the page are temporarily removed.


Reproducible: Always

Steps to Reproduce:
1. Visit http://web.abo.fi/~asignell/flicker.html
2. Click on the scrollable content, no flickering.
3. Scroll down or right and click again, flickers.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 2

8 years ago
Seems to work correctly in 3.6.10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.