places.xul: mousewheel trying to open the clipboard content instead of the bookmark

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: paul.ardemue, Unassigned)

Tracking

3.5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

When you use the bookmark manager by browsing to chrome://browser/content/places/places.xul the mousewheel button does not properly open your bookmarks (though it works perfectly using Bookmarks > Organize bookmarks). Actually it opens them (in new tabs as expected) but does not wait for the page to load and switches the URL with your clipboard content.


Reproducible: Always

Steps to Reproduce:
1. Type anything in your search bar then copy it
2. Open chrome://browser/content/places/places.xul
3. Click any bookmark with the mousewheel button
Actual Results:  
It opens a new tab, loads the bookmark URL, then switches that URL with your clipboard content.

Expected Results:  
It should open the clicked bookmark item in a new tab.
could you try in safe mode please? http://support.mozilla.com/kb/Safe+Mode
Version: unspecified → 3.1 Branch
(Reporter)

Comment 2

10 years ago
I just did and it does not change anything.
(Reporter)

Comment 3

10 years ago
I've just noted that it does not replace the URL with the clipboard content as in Ctrl + V but with the clipboard content as in mousewheel button click : if I select some text in a page in firefox, that text can be pasted using the mousewheel button, and that text does not necessarily match the clipboard content.
this could be due to an external mouse manager software. i can't see why middle click should try to paste.
i cannot reproduce
Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.