Hover blink with on disabled menu items in context menu of bookmarks popup

REOPENED
Unassigned

Status

()

Core
Event Handling
REOPENED
9 years ago
7 months ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 352365 [details]
screenshot

To reproduce:
- Make sure you have a certain minimum amount of bookmarks (otherwise the bug doesn't occur for some reason).
- Right-click some bookmark to open the context menu. Make sure the 'Paste' menu-item is disabled (by not having a bookmark item in your clipboard).
- Hover over the 'Paste' menu-item.

Result:
Quite often, that disabled menu-item is not highlighted and gets highlighted only sporadically, while moving the mouse. This is a behavior similar as described in bug 306149.

I seem to get a regression range between 2008-10-09 and 2008-10-10:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-10-09+03%3A00%3A00&enddate=2008-10-10+05%3A00%3A00
So this seems to me a regression somehow from bug 69710 somehow, since that one added text-shadow: 1px 1px ThreeDHighlight; css to menu-items.
But that's probably not the fundamental cause of this bug.

Comment 1

8 years ago
This is  as same as Bug 492960 -  It flickers when I move a mouse on an disabled context menuitem of pull down Bookmarks menu

Comment 2

6 years ago
I face same issue as well. (Hover blink in context menu of bookmarks popup)
but, not only on disabled menu item, it happend on all menu items.

Step to reproduce:
1) Open and website got marquee running text.
2) Then right click any bookmark to bring out context menu of bookmarks popup.

Result:
Same as Martijn Wargers mentioned in first post.

Comment 3

6 years ago
addional information:
- my case only happen while website in current tab contains marquee content.
- If the marquee website is at background tab, the problem won't occur.

Comment 4

6 years ago
just realize it is open bugs since 2008.
no body to fix this bug?
(Reporter)

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.