S element not rendering

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Chris Petersen, Assigned: clayton)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Strict DTD Invalid Page], URL)

(Reporter)

Description

18 years ago
Build: 2000072704
Platforms: All
Expected Results: The S element should render it's contents with a strike-
throught.
What I got: The page is blank.

Stesp to reproduce:

1) Open http://slip/projects/marvin/html/s.html.

2) Page is blank.

3) Text with strike-throght should appear.

4) This is only a problem with S element. The STRIKE element will rendered 
correctly.
(Reporter)

Comment 1

18 years ago
Nominating for beta3. S element has been support since HTML 3.0.
Keywords: nsbeta3
INVALID. That web page is not valid as the <S> is inline content and it is
included directly within the <BODY> which (in Strict mode) only accepts
block level content.

See http://validator.w3.org/ ;-)
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Reop
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Whiteboard: [Strict DTD Invalid Page]
(Reporter)

Comment 4

18 years ago
Set the DOCTYPE to transitional which it should have been. Now S element is 
rendering properly.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.