Closed Bug 469019 Opened 13 years ago Closed 13 years ago

gfxRect shouldn't be forward declared as a class

Categories

(Core Graveyard :: GFX, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: timeless, Assigned: timeless)

References

()

Details

Attachments

(1 file, 1 obsolete file)

c:\home\mozilla.org\mozilla-central\dbg-firefox-i686-pc-mingw32\dist\include\thebes\gfxRect.h(57) : warning C4099: 'gfxRect' : type name first seen using 'class' now seen using 'struct'
        c:\home\mozilla.org\mozilla-central\dbg-firefox-i686-pc-mingw32\dist\include\gfx\nsIImage.h(48) : see declaration of 'gfxRect'
nsXULElement.cpp
Building deps for /c/home/mozilla.org/mozilla-central/content/xul/content/src/nsXULElement.cpp
c:\home\mozilla.org\mozilla-central\dbg-firefox-i686-pc-mingw32\dist\include\thebes\gfxMatrix.h(67) : warning C4099: 'gfxMatrix' : type name first seen using 'class' now seen using 'struct'
        c:\home\mozilla.org\mozilla-central\dbg-firefox-i686-pc-mingw32\dist\include\gfx\nsIImage.h(47) : see declaration of 'gfxMatrix'


Defined as a function in:
    * gfx/thebes/public/gfxRect.h (View CVS log or CVS annotations) (View Hg log or Hg annotations)
57 struct THEBES_API gfxRect {
          o line 63 -- gfxRect(const gfxRect& s) : pos(s.pos), size(s.size) {}
          o line 64 -- gfxRect(const gfxPoint& _pos, const gfxSize& _size) : pos(_pos), size(_size) {}
          o line 65 -- gfxRect(gfxFloat _x, gfxFloat _y, gfxFloat _width, gfxFloat _height) : 

Defined as a struct type in:

    * layout/svg/base/src/nsSVGUtils.h (View CVS log or CVS annotations) (View Hg log or Hg annotations)
          o line 74 -- struct gfxRect; 

Defined as a (forwarded) class in:

    * gfx/public/nsIImage.h (View CVS log or CVS annotations) (View Hg log or Hg annotations)
          o line 48 -- class gfxRect;
Attached patch switch from class to struct (obsolete) — Splinter Review
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #352426 - Flags: review?(bzbarsky)
gfxMatrix is a struct too.
Attachment #352426 - Flags: review?(bzbarsky) → review+
Attachment #352513 - Flags: review?(longsonr)
Attachment #352513 - Flags: review?(longsonr) → review+
Duplicate of this bug: 465081
Attachment #352513 - Flags: superreview?(roc)
Attachment #352513 - Flags: superreview?(roc) → superreview+
Attachment #352426 - Attachment is obsolete: true
Keywords: checkin-needed
Whiteboard: [needs landing]
Attachment #352513 - Attachment description: oops, incomplete patch/bug → oops, incomplete patch/bug [Checkin: Comment 5]
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [needs landing]
Target Milestone: --- → mozilla1.9.2a1
Product: Core → Core Graveyard
Blocks: 526601
No longer blocks: 526601
You need to log in before you can comment on or make changes to this bug.