zooming in while page is loading messes up widgetstack

VERIFIED FIXED

Status

Fennec Graveyard
Panning/Zooming
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Gavin, Assigned: froystig)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Details

STR:
1) Load store.mozilla.org
2) While page is loading, double click center image to zoom in
3) Wait for page to load

After the page loads, the enter page is shifted to the left (offscreen), and you can't pan over (the left sidebar comes in immediately). Also can't bring up the right sidebar at all.
Flags: blocking-fennec1.0?
I ran into this (or a very similar issue) while testing Alpha2.  What happens is the page is stuck partially scrolled down and you cannot scroll back up.  This is the case for any pages already panned.

here are the steps to repro:
1) search for fennec in google
2) open a new tab
3) open www.miamiherald.com
4) when it finishes loading, pan down a few pages
5) zoom in
6) switch tabs back to google (sometimes this doesn't load)
7) now switch back to miami herald
8) observe no more zoom and you are stuck partway down the page with no option to pan to the top.


restarting the browser fixes this issue.

Taking this a step further, closing the secondary tab (miamiherald.com) and back on the original tab (currently at google), I browse to cnn.com in the url bar and it loads partially panned (WTF) just like miamiherald.com was.  Then the browser crashes on me.
Duplicate of this bug: 471228
Blocks: 473596

Updated

9 years ago
tracking-fennec: --- → 1.0+
Blocks: 496338

Updated

9 years ago
Flags: blocking-fennec1.0?

Updated

9 years ago
Assignee: nobody → rfrostig
I was able to reproduce Joel's problem from December with a current build of Fennec on the desktop.

Comment 4

8 years ago
this is mostly fixed (no more widgetstacks), and there are other bugs on the new zooming related issues
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified with maemo nightly from 20090818
Status: RESOLVED → VERIFIED
Component: General → Panning/Zooming
You need to log in before you can comment on or make changes to this bug.