WinCE Shunt Build Layout Too Complicated

VERIFIED DUPLICATE of bug 474737

Status

()

Core
General
VERIFIED DUPLICATE of bug 474737
10 years ago
10 years ago

People

(Reporter: wolfe, Unassigned)

Tracking

({mobile})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 352484 [details] [diff] [review]
v1.0 patch

Right now, there are two copies of all the tools needed for building the WinCE / WinMobile 6 XULRunner and Fennec.  The only difference between those two versions of tools is one line in a header file.

Also, the Visual Studio projects needed to build the mozce_shunt.dll library have way too many platform types that are not being actively developed (2003 PPC and Smartphone, WM5 PPC and Smartphone, Debug and Release versions of everything).

As the mozce_shunt Visual Studio projects are laid out right now, a new clone of mozilla-central will fail to properly build the mozce_shunt from within Visual Studio.

For these reasons, the WinCE / WinMobile 6 compilation and linking tools source code and mozce_shunt building code should be trimmed down, which will make them both more maintainable.
Attachment #352484 - Flags: review?(doug.turner)

Comment 1

10 years ago
Comment on attachment 352484 [details] [diff] [review]
v1.0 patch

in meetings this week -- brad can you swing at this review.  otherwise, let me know and I can get to it next week.
Attachment #352484 - Flags: review?(doug.turner) → review?(bugmail)
John, instead of deleting the existing tools and creating new ones, it would be useful to use hg rename.
This is actually cleaning up the tools which was fixed in bug 474373
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474373
Brad, I'm sure you entered the wrong bug number. I cant see any correlation between this bug and bug 474373 which is about MozMill.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

10 years ago
This is actually cleaning up the tools, which was fixed in BUG 474737 -- not 474373.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474737
Yeah. That's much better. Verified.
Status: RESOLVED → VERIFIED
Attachment #352484 - Flags: review?(bugmail)
You need to log in before you can comment on or make changes to this bug.