Closed Bug 469090 Opened 14 years ago Closed 14 years ago

Editing vcard info on identity of email account starts with empty form

Categories

(MailNews Core :: Address Book, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b2

People

(Reporter: fritz.heinrichmeyer, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.0.4) Gecko/2008111319 Ubuntu/8.10 (intrepid) Firefox/3.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.9.1b3pre) Gecko/20081204 Lightning/1.0pre Thunderbird/3.0b1


Even when there is already vcard info in use when sending mail, the vcard dialog shows empty entries, so i have to insert all information from scratch.


Reproducible: Always

Steps to Reproduce:
1. create vcard entry
2. send mail with vcard attachment
3 [review]. try to edit your attached vcard information
Actual Results:  
vcard forms are empty

Expected Results:  
vcard forms should show old entries
I see this, regression from bug 63941. Wayne, we definitely need litmus tests for the vcard editing in account manager - whenever we do a change to AB cards, we tend to break it.
Assignee: nobody → bugzilla
Blocks: 63941
Status: UNCONFIRMED → NEW
Component: Account Manager → Address Book
Ever confirmed: true
Flags: in-testsuite?
Keywords: regression
OS: Linux → All
Product: Thunderbird → MailNews Core
QA Contact: account-manager → addressbook
Hardware: PC → All
Target Milestone: --- → Thunderbird 3.0b2
Version: unspecified → Trunk
Summary: editing vcard info on idendity of email account starts with empty form → Editing vcard info on identity of email account starts with empty form
Attached patch The fix (obsolete) — Splinter Review
The problem is that we're collapsing an element that is no longer in the dialog. I'm not sure why this isn't getting to the error console, I guess something somewhere is catching it.

Anyway, the solution is to replace by elements that are there, and define a few extra ids so that we can easily do this.
Attachment #352509 - Flags: superreview?(neil)
Attachment #352509 - Flags: review?(bienvenu)
Attachment #352509 - Flags: superreview?(neil) → superreview-
Comment on attachment 352509 [details] [diff] [review]
The fix

homeTabButton needs to be hidden, not collapsed, while abHomeTab should be neither collapsed nor hidden. (The other elements probably don't care.)
Attached patch The fix v2Splinter Review
Revised as per Neil's suggestions
Attachment #352509 - Attachment is obsolete: true
Attachment #352518 - Flags: superreview?(neil)
Attachment #352518 - Flags: review?(bienvenu)
Attachment #352509 - Flags: review?(bienvenu)
Attachment #352518 - Flags: superreview?(neil) → superreview+
(In reply to comment #1)
> I see this, regression from bug 63941. Wayne, we definitely need litmus tests
> for the vcard editing in account manager - whenever we do a change to AB cards,
> we tend to break it.

vcard is https://litmus.mozilla.org/show_test.cgi?id=5487 in FFT, subgroup 919 Mail composition. It seems vague.  Also, perhaps a piece needs to be added to account settings subgroup 923.  Setting in-litmus? so we follow up with this. And adding note to postmortem that we will want to do FFT for beta 2.
Flags: in-litmus?
Attachment #352518 - Flags: review?(bienvenu) → review+
(In reply to comment #5)
> Setting in-litmus? so we follow up with this.

Yes, thanks - I set the wrong flag earlier.
Flags: in-testsuite?
Patch checked in: http://hg.mozilla.org/comm-central/rev/c4e08d2741fc
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Duplicate of this bug: 482083
(In reply to comment #5)
> (In reply to comment #1)

> vcard is https://litmus.mozilla.org/show_test.cgi?id=5487 in FFT, subgroup 919
> Mail composition. It seems vague.  Also, perhaps a piece needs to be added to
> account settings subgroup 923.  Setting in-litmus? so we follow up with this.
> And adding note to postmortem that we will want to do FFT for beta 2.

Agreed that one should be split in more than one TC.
You need to log in before you can comment on or make changes to this bug.