Tags are not taken into account when pressing Ctrl+Enter in the location bar.

RESOLVED DUPLICATE of bug 469140

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 469140
9 years ago
9 years ago

People

(Reporter: Rick Alther, Unassigned)

Tracking

({verifyme})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 (CK-IBM) Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 (CK-IBM) Firefox/3.0.4

This bug is very closely related to bug 469140, but I am entering it separately since they involve different features of bookmarks (though in 3.x keywords may be just a holdover and automatically converted to a tag for all I know).

* The same behavior applies to bookmarks that have tags associated withe them
and I type the tag and press Ctrl+Enter.  It goes to 'www.tag.com' rather than
the associated URL.

IMO Ctrl+Enter should be struck dead or open the URL in another background tab.
 That way the UI is simpler and more consistent.  The user only needs to
remember that 'Ctrl+[click/enter]' opens a link in another tab.  It's much
easier to tell new people "just Ctrl+[click/enter] on any link to open a tab"
than to tell them to remember to use Alt for some and Ctrl for others,
depending on where you are.  That's just an inconsistent UI. I haven't checked
them all, but isn't Firefox the only browser to copy this IE 'feature'?  I
don't recall Opera, Konqueror or Safari doing this (but I don't have them avail
to test ATM). 

Another reason this feature is outdated are the numerous new TLDs out there
(e.g. .biz and .info) as well as the country TLDs.  Firefox is supposed to be
an international browser, yet this feature is inherently US centric.  

If it's decided that this feature should still live, it should take into
account keywords and tags as well.
1) first, it should just check to see if the location is a single word.  If
it's got a '.' in it, it shouldn't even be considered for 'fixing'.
2) Bookmarks should be searched for matching keywords/tags and use the
associated URL if it finds one.
3) Only then should Firefox attempt to 'fix' it.

Reproducible: Always

Steps to Reproduce:
1. Open a bookmark and set a tag for it.  It's best to set the keyword to
something not part of the URL, to avoid confusion.  e.g. don't set a keyword of
'mail' for 'mail.google.com'.
2. Type the keyword in the location bar and press enter to ensure the keyword
is working properly.
3. Open a new tab.
4. Type the keyword into the location bar and press Ctrl+Enter. 
Actual Results:  
Notice it prepends 'www' and appends 'com', so the URL takes the form of
'www.keyword.com'.  It does not look up the keyword and use the associated URL
as it should.


Expected Results:  
It should search the keywords and go to the associated URL prior to attempting
to "fix" the entered URL.
(Reporter)

Updated

9 years ago
Component: General → Location Bar and Autocomplete
(Reporter)

Comment 1

9 years ago
This bug is being submitted as requested from the comments in bug 233853.
QA Contact: general → location.bar
(In reply to comment #0)
> This bug is very closely related to bug 469140, but I am entering it separately
> since they involve different features of bookmarks (though in 3.x keywords may
> be just a holdover and automatically converted to a tag for all I know).
> 
> * The same behavior applies to bookmarks that have tags associated withe them
> and I type the tag and press Ctrl+Enter.  It goes to 'www.tag.com' rather than
> the associated URL.

Rick, I think there's a misunderstanding on your side as to the difference between keywords and tags. Keywords will never be automatically converted into tags, the functional concept is entirely different.
* Keywords are a shortcut to open a single bookmark (e.g. type "g" into location bar to open www.google.com), which may or may use a keyword search (e.g. type "g searchword" to open the google query for searchword).
* Tags are labels used to classify bookmarks into logical groups, and you can assign the same tag to as many bookmarks as you please.
For that reason, the expected behaviour you describe in comment #0 can never apply to tags, but only to keywords. And that's your other bug 469140.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 469140
This bug should be "verified" duplicate (or invalid). Reporter mixes up tags and keywords.
Keywords: verifyme
(Reporter)

Comment 4

9 years ago
Agreed.  This was a misunderstanding about tags on my part.  This bug can be closed.
You need to log in before you can comment on or make changes to this bug.