Can't drag&drop bookmarks from Location Bar

VERIFIED DUPLICATE of bug 469465

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 469465
10 years ago
10 years ago

People

(Reporter: Hermann Schwab, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
working  : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081207 SeaMonkey/2.0a3pre
Built from http://hg.mozilla.org/releases/mozilla-1.9.1/rev/8c5b036c35d3
BuildID:20081207001338 1.9.1.3263

regressed: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081208 SeaMonkey/2.0a3pre
BuildID:20081208001325 1.9.1.3264

Dragging the favicon from the location bar seems to work normally, but dropping to create bookmark in personal toolbar, a folder in P.T. or in the bookmarks manager window doesn't work.

Message from Error console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsIRDFService.GetDataSource]"  nsresult: "0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)"  location: "JS frame :: chrome://communicator/content/bookmarks/bookmarks.js :: anonymous :: line 1486"  data: no]


chrome://communicator/content/bookmarks/bookmarks.js:

  createBookmark: function (aName, aURL, aCharSet, aDefaultName)
  {
    if (!aName) {
      // look up in the history ds to retrieve the name
      var rSource = RDF.GetResource(aURL);

Line 1486:
      var HISTDS  = RDF.GetDataSource("rdf:history");


      var nameArc = RDF.GetResource(NC_NS+"Name");
      var rName   = HISTDS.GetTarget(rSource, nameArc, true);
      aName       = rName ? rName.QueryInterface(kRDFLITIID).Value : aDefaultName;
      if (!aName)
        aName = aURL;
    }
    if (!aCharSet) {
      var fw = document.commandDispatcher.focusedWindow;
      if (fw)
        aCharSet = fw.document.characterSet;
    }
    return BMSVC.createBookmark(aName, aURL, null, null, aCharSet);
  },

Comment 1

10 years ago
Have you tried in Safe Mode?
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081211 SeaMonkey/2.0a3pre

created & used new virgin profile, drop doesn't work.

Seems to be caused by  Bug 382187 -  use places for SeaMonkey history 

http://hg.mozilla.org/comm-central/rev/28012b9430e5
Depends on: 382187

Comment 3

10 years ago
I think this is serious enough to be on the blocking radar.
Flags: blocking-seamonkey2.0a3?

Comment 4

10 years ago
Neil has a patch in Bug 469465
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 469465
No longer depends on: 382187
Resolution: --- → DUPLICATE
Duplicate of bug: 469465
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED

Updated

10 years ago
No longer depends on: 469465
Flags: blocking-seamonkey2.0a3?

Comment 5

10 years ago
Sorry for not searching for an existing bug on this.
You need to log in before you can comment on or make changes to this bug.