Email addresses with entries without email address generate an error

RESOLVED DUPLICATE of bug 280951

Status

RESOLVED DUPLICATE of bug 280951
10 years ago
8 years ago

People

(Reporter: mitra_lists, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081130 Shredder/3.0b1pre

If you have a mailing list with no email address it will generate an error. 

Reproducible: Always

Steps to Reproduce:
1.Create mailing list in OSX Address Book Ccc
2.Create entry "AAA Aaa" home=aaa@aaa.com
3.Create entry "Bbb Bbb" with no email address
4. Add Aaa and Bbb to Ccc
5. In TB
6. Create new message
7. Select Ccc as the receiver
Actual Results:  
There will be an SMTP error when the email is sent.

Expected Results:  
I believe it should send the email to Aaa, but either ignore Bbb or generate a warning dialogue listing any recipients it can't email and give option "OK" to send to the valid recipients.

Having entries in Address Book with no valid email address is totally normal, e.g. because you only know the phone number and remember that many OSX users will by syncing Address Book to their mobile phone.

Grouping them into Folders is also normal - e.g. I have a "Clients" folder some of whom don't have email addresses.

Wanting to mail a folder with some invalid addresses is also normal - i.e. I want to email all my clients a xmas card, would like it to go to all with valid email addresses, and ideally get a warning for those that don't. 

The workaround - nasty but works - open mailing list in Address Book, select All, and drag to outgoing email. Since most people won't figure this out, I think it qualifies as a "Normal -fix it" bug.
this is a dupe -  not sure what component it's in but should be easy to find
Component: General → Message Compose Window
QA Contact: general → message-compose
Whiteboard: dupeme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 280951
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.