CTRL+H should be used for History, not Home

VERIFIED FIXED

Status

()

Core
Keyboard: Navigation
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: mats, Assigned: don)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
DESCRIPTION:
Keyboard shortcut CTRL+H is currently tied to "Home" in Go menu. This is BAD.
Nearly 100% of the current browser market uses CTRL+H for "History", including
all of Netscape's erlier products. Going against a de facto standard like this
will make many many many users like myself to #!%!%/%¤! your product.

Suggestion: use ALT+Home like IE5 to load Home page

STEPS TO REPRODUCE:
1. start Mozilla, type CTRL+H

ACTUAL RESULTS:
Home page is loaded.

EXPECTED RESULTS:
History window should be opened

DOES NOT WORK CORRECTLY ON:
Mozilla nightly build 2000-07-28-08 on Windows 98.

WORKS CORRECTLY ON:
Netscape Communicator 4.x
Netscape Navigator 3.x
IE 5.00 (and erlier too?)
Opera 4.01

Comment 1

18 years ago
I agree with it.
other opinions...?
Keywords: 4xp

Comment 3

18 years ago
I agree it should be alt+home, since back/forward is now alt+<- and alt+-> (and 
it wouldn't make sense to have two of the three navigation accelerator keys 
have alt modifiers, and one have a ctrl modifier).

But we don't have to worry, since Ben already fixed this :)
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

18 years ago
Agreed to, is this in the spec? H should always be history!

Comment 5

18 years ago
Regardless, it's fixed...
feel free to verify these bugs if i don't get to 'em beforehand. if you do, pls
remove the verifyme keyword when you do verify such a bug. thx!
Keywords: verifyme

Comment 7

18 years ago
verified. using the 2000081308 nightly on win2k
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.