If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Find dialog should pre-select previous search text

VERIFIED DUPLICATE of bug 60268

Status

SeaMonkey
UI Design
P3
normal
VERIFIED DUPLICATE of bug 60268
17 years ago
9 years ago

People

(Reporter: mats, Assigned: Simon Fraser)

Tracking

({helpwanted})

Trunk
Future
x86
Windows 98
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
DESCRIPTION:
Find dialog should pre-select previous search text.

STEPS TO REPRODUCE:
1. goto http://www.mozilla.org
2. press CTRL+F
3. Enter the word mozilla in the text field and press RETURN (or click Find)
4. press ESC (or click Cancel)
5. press CTRL+F

EXPECTED: the word "mozilla" should be pre-selected.
ACTUAL: it isn't.

DOES NOT WORK CORRECTLY ON:
Mozilla nightly build 2000-07-28-08 on Windows 98 SE.

WORKS CORRECTLY ON:
Communicator 4.74 on Windows 98 SE.
MSIE 5.00 on Windows 98 SE.
(and nearly all other Windows applications)

Updated

17 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 1

17 years ago
this works for me with 073108 M18 mozilla build on NT, 98 and OS9
(Reporter)

Comment 2

17 years ago
I still see this problem. Build 2000-08-04-20-M18 on Windows 98 SE.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

17 years ago
works for me (080608, M18 win95)
WORKSFORME, 20000819, WinNT 4.

<shrug>

Gerv

Comment 5

17 years ago
marking wfm, as per above comments.  Reporter, please reopen if needed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
Bug is still there. I have seen this behaviour in all builds I have downloaded
the past month. Bug is present on both Windows 98 SE and NT. In build
2000-08-28-08 (w. new Modern skin) the problem is even worse, now I have to
explicitly place focus in the search string textbox before I can type.
Severity: minor → normal
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

17 years ago
mats, have you deleted your old profiles and mozregistry.dat file?  I still
cannot reproduce this.
(Reporter)

Comment 8

17 years ago
Reinstalled build 2000-08-28-08 once again, same problem. Here's what I did:
1. Uninstall Mozilla from Windows 98 ("Control Panel" -> "Add/Remove Programs")
2. Manually delete the entire C:\Program Files\Mozilla catalog
3. Manually delete everything under C:\Windows\ named moz* or Moz*
4. reboot
5. install build 2000-08-28-08 using the mozilla-win32-installer.exe

No change I'm afraid, the original description and my comment dated 2000-08-28
are still accurate.

Comment 9

17 years ago
mats, I'm sorry.  I'm an idiot.  I've been misreading this bug the whole time.
I thought you were saying pre-filled with the word, not preselected as in
highlighted.  Confirmed with 082915 mozilla build on NT, win2K.  over to XPApps
Assignee: asa → ben
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: GUI Features
Ever confirmed: true
QA Contact: doronr → sairuh
this belongs to either simon or bill...
Assignee: ben → sfraser

Comment 11

17 years ago
I looked at this today on win98 using comm build from 9/12 and this is what i
found.  opened browser, selected home page, and selected ctrl-f.  Put in the
search word.  the first instance was selected and then closed the dialog.  the
word remained highlighted in the grey selection.  reopened dialog and the word
got reselected.  what am i doing wrong?  this seems to be working right for me.
(Assignee)

Comment 12

17 years ago
Is the test *in the dialog* reselected? What the filer wants is for the text of 
textfields to get automatically selected on focus (Mac does this normally). I 
agree with them, but I think the solution should be in the toolkit, not on a per-
dialog basis.

Comment 13

17 years ago
setting this to future.

anthonyd
Target Milestone: --- → Future
(Assignee)

Comment 14

17 years ago
*** Bug 54442 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
Future... No one will use a product with this amount of "features", so no future 
for mozilla/ns6, when such a bugs will not be fixed for RTM.
Keywords: helpwanted

Comment 16

17 years ago
*** Bug 58495 has been marked as a duplicate of this bug. ***
bug 60268 has a patch submitted, so gonna dup this one...

*** This bug has been marked as a duplicate of 60268 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 18

17 years ago
Verifying as a duplicate of bug 60268
'Previous search text in find dialog should be selected when opened'
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.