If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Widget needs a resize callback

RESOLVED FIXED

Status

Core Graveyard
Embedding: GTK Widget
P3
normal
RESOLVED FIXED
17 years ago
6 years ago

People

(Reporter: rusty.lynch, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If the widget request a new window throught the new_window callback, the
application doesn't know what size to make the window, only what chrome to use.
This is by design.  After the dom window has requested the widget (via
nsIBaseWindow) to create a new window, the dom window (implemented in
nsGlobalWindow::OpenInternal()), ask the widget (again through nsIBaseWindow) to
resize to the requested size.  

Our widget code just updates member variable with the new sizes and does nothing
else.  What we need is another callback that the application registers with the
widget to catch these request and do as the application sees fit.

My tree (at work) currently has this implemented but in an out-of-date tree, so
I need to update my patch to the cvs tip.  I will attach an up to date patch
soon.

Comment 1

17 years ago
->blizzard
Assignee: pavlov → blizzard
(Assignee)

Comment 2

17 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.