Crash when visiting http://www.nyteknik.se [@ js_HashString ]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Bengt-Erik Soderstrom, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 352702 [details]
Crash report bp-4c864aa0-d598-4734-b30e-4fe452081212 

Crash when visiting the above site. It happens all the times after about one second when the page is almost fully loaded. As the crash occurs in js3250.dll, I first had some thoughts maybe it was related to my attempts to localize into sv-SE, but a fresh build to the default en-US shows the same bad result.

Crash report bp-4c864aa0-d598-4734-b30e-4fe452081212 is attached.

Other crash reports from me in this issue:
bp-b8c90623-4ff0-40d5-84d1-b076b2081211
bp-1de34332-6f68-4458-9852-deac12081211
bp-3b6d9cd6-91fd-4f0d-b97e-4aad52081211
bp-cd8b70a2-dc0e-47af-8483-1d25a2081211

Builds before Dec 11 were OK.
(Reporter)

Comment 1

10 years ago
Maybe my building environment is of interest;

about:buildconfig

Source

Built from http://hg.mozilla.org/mozilla-central/rev/97972bac287f+
Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version Compiler flags
cl 14.00.50727.762 -TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -O1
cl 14.00.50727.762 -GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb DNDEBUG -DTRIMMED -O1

Configure arguments
--enable-application=browser --disable-debug --disable-tests --disable-jemalloc

Disable jemalloc because it is not supported in VC8 Express
crash Reports from self-compiled buidls are useless because the server doesn't have symbols for it.

PLease post a crash ID from an official Mozilla.org build, you don't need to attach anything because dumps or technical details are also useless. THe other way would be do build a debug build and posting a stacktrace from the debugger.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081211 Minefield/3.2a1pre

I verified that it crashes, but until now only with javascript.options.jit.content to true.
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081211
> Minefield/3.2a1pre
> 
> I verified that it crashes, but until now only with
> javascript.options.jit.content to true.

OK. That at least points in what direction the solution lies.
Sorry for the useless crash report. Perhaps Ria's got a useful one.
(Reporter)

Comment 5

10 years ago
I can't test right now. The site is down. 'Guru Meditation'
(Reporter)

Comment 6

10 years ago
I have verified with Mozilla Nightlies as follows:

20081211042349  is OK
20081212040742  is not OK

But for some reason it looks like the nightly from 20081212 is crashing by itself after a while...irrespectivly how the jits are set
Yeah, is probably one of the checkins yesterday: Thu Dec 11 03:23:21

http://crash-stats.mozilla.com/report/index/66fbbb51-c8ea-41de-9367-b971d2081212
I get the same report on Windows XP.
Summary: Crash when visiting http://www.nyteknik.se → Crash when visiting http://www.nyteknik.se [@ js_HashString ]
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Target Milestone: Firefox 3.2a1 → ---
(In reply to comment #6)
> 
> But for some reason it looks like the nightly from 20081212 is crashing by
> itself after a while...irrespectivly how the jits are set

Yes, sometimes when it is idle for a while it crashes even with a new profile on the about:crashes site, but then the report is quite different. On http://www.nyteknik.se it is always the same report.
This looks the same as bug 465214.
Depends on: 465214
(Reporter)

Comment 10

10 years ago
(In reply to comment #9)
> This looks the same as bug 465214.

Agreed. If you look on my today's crash report (from today's Nightly) the nyteknik crash occurs in js/src/jsstr.cpp:3115. Nevertheless they might still be related.

Crash report: 65f640cf-b181-4b15-a98c-4de572081213
Duplicate of this bug: 471178

Comment 12

9 years ago
It seems like the bug got into the 3.1b3pre nightlies, and most people are encountering it on meebo:
http://crash-stats.mozilla.com/report/list?range_value=2&range_unit=weeks&version=Firefox%3A3.1b3pre&signature=js_HashString

Reproduced with 3.1b3pre build 20081229034332 both on meebo and on nyteknik.

Comment 13

9 years ago
Nominated because crashing on meebo seems bad.  (Thanks for the help roc)

To be more specific about the crash at meebo: it seems to happen whenever an IM window opens (either through you opening it or through receiving an IM).
Flags: blocking1.9.1?

Comment 14

9 years ago
We also get a crash that looks like this bug on this web site:
http://www.recept.nu/1.133830/linda_skugge/varmratter/kottfars/cowboysoppa

Discovered on:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090106 Shiretoko/3.1b3pre

... so if this is the same bug, this seems to affect the Mac platform as well.

The stack trace for that site is given here, and matches the one given in comment 7 on this bug:
http://forums.mozillazine.org/viewtopic.php?p=5407925#p5407925

The workaround for that site about disabling JIT also applies, just as comment 3 explains here.

Just telling, in case this other web site will help narrowing down the issue, in combination with what we see at the original site.

Comment 15

9 years ago
As of the numerous fixes to TraceMonkey in the 20090107 build, I can no longer reproduce either the crash at the site I reported yesterday, or the site mentioned in this bug (www.nyteknik.se).
WFM per comment 15.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Flags: blocking1.9.1?

Comment 17

9 years ago
Yes, the bug seems to be gone in 3.1b3pre build 20090107042444; couldn't
reproduce on either meebo or nyteknik.  But can't speak for 3.2a1pre....
(Reporter)

Comment 18

9 years ago
Agree with comment 15 and 16, my fresh builds of 3.2a1 do no longer show this bug.

Comment 19

9 years ago
I confirm that http://www.yell.ru can be opened with build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090108 Shiretoko/3.1b3pre
Crash Signature: [@ js_HashString ]
You need to log in before you can comment on or make changes to this bug.