Background of some images is displayed as yellow-ish when it should be white instead

RESOLVED DUPLICATE of bug 460629

Status

()

RESOLVED DUPLICATE of bug 460629
10 years ago
10 years ago

People

(Reporter: michael-hofmann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

Some images (encountered only .jpg's so far, but could affect other image formats, too) are shown with a pastel yellowish background instead of a while background color. This does not affect all images with white in them, but only some; the problem is reproducible.

Reproducible: Always

Steps to Reproduce:
Just two examples:
1. Visit http://www.photozone.de. The four pictures of lenses have a pastel yellow colored background; it should be white instead.
- or -
2. Visit  http://www.meetin.org. The upper left logo has a pastel yellow colored background; it should be white instead.
Actual Results:  
Pictures on some web pages have a pastel yellow colored background.

Expected Results:  
White image background instead of yellow-ish image background.

At first I thought this might be a transparency issue, but since it affects JPEG files that don't know of any inherent transparency (unlike PNGs for example), the problem must be of a different kind.

This problem seems to resemble Bug 450923 somehow, but that bug appeared to be far more severe, see attachment there. Could the remaining problem be a remainder of trying to fix Bug 450923?
(Reporter)

Comment 1

10 years ago
Created attachment 352715 [details]
Image background color for some images is yellow-ish; should be white

Start page of http://www.photozone.de

Comment 2

10 years ago
Both the bugs mentioned are marked duplicates of bug 460629 which is not fixed in 3.1b2 but will be in 3.1b3. The severity will then depend on the profile that you are using for your monitor.

The images seem to have a colour profile. Can you try with gfx.color_management.mode set to 0?
(Reporter)

Comment 3

10 years ago
Setting gfx.color_management.mode to 0 doesn't change the appearance of the images for me - they're still yellow.

Comment 4

10 years ago
(In reply to comment #3)
> Setting gfx.color_management.mode to 0 doesn't change the appearance of the
> images for me - they're still yellow.

I forgot! IIRC you also need to restart Firefox after changing this preference.
(Reporter)

Comment 5

10 years ago
Ok, disabling color management and restarting "fixed" it.
The issue itself is that you have a wrong ICC profile for your Monitor.
Which Monitor and ICC Profile are you using ?

Note: 
Bug 460629 tries to detect broken profiles but it can not detect all faulty display profiles. Can you please check a nightly trunk build ?
Component: General → GFX: Color Management
Product: Firefox → Core
QA Contact: general → color-management
Michael, any chance you could try things out with a nightly (latest-trunk) to see if it detects and disables your profile?

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460629
You need to log in before you can comment on or make changes to this bug.