Closed Bug 469346 Opened 11 years ago Closed 11 years ago

Plugin notification pref needs to get out of the Enable Plugins for MailNews groupbox

Categories

(SeaMonkey :: Preferences, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0a3

People

(Reporter: stefanh, Assigned: stefanh)

References

Details

Attachments

(1 file, 1 obsolete file)

I think there are 2 reasons for not having the notification pref in the Advanced: Scripts & Plugins pane in the "Enable Plugins for" groupbox:

1) It's a bit confusing, because one might get the impression that they're connected.

2) By looking at the code, it seems that the notification pref checkbox won't be visible if you choose to not install MailNews.
I've been playing a bit with this and for me everything fits in to the panel even with a new groupbox (Classic and Modern on mac). Not sure about win/nix, though. Imo, a groupbox is the best solution since then the indentation will be the same (look at the Appearance panel and notice how the "Show tooltips" checkbox look together with the surrounding groupboxes).
I'd like Jens to comment on this, since it might be that he tested this and it didn't fit.
Assignee: nobody → stefanh
mxr didn't found "mailPrefOverlay.xul" ;-)
Attachment #352759 - Attachment is obsolete: true
(In reply to comment #2)
> Created an attachment (id=352759) [details]
> Put the checkbox in its own groupbox
> 
> I'd like Jens to comment on this, since it might be that he tested this and it
> didn't fit.

I didn't and it fits. :-)
Attachment #352760 - Flags: superreview?(neil)
Attachment #352760 - Flags: review?(neil)
Comment on attachment 352760 [details] [diff] [review]
Same as before, but fix a spelling error

I added an id to the new groupbox, not really sure if it's necessary. A comment from Karsten in some bug I don't remember keeps echoing in my head, but that could just be me and the fact that is friday and I've been working all week and not had enough sleep.
Comment on attachment 352760 [details] [diff] [review]
Same as before, but fix a spelling error

>+      <caption label="&whenPluginsRequired.description;"/>
You need to remove the trailing : from the entity, and also rename it to .label for consistency and so localisers notice ;-) sr=me with that fixed.
Attachment #352760 - Flags: superreview?(neil)
Attachment #352760 - Flags: superreview+
Attachment #352760 - Flags: review?(neil)
Attachment #352760 - Flags: review+
Pushed changeset d88275bc5d35 to comm-central (with comment #6 addressed).
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0a3
You need to log in before you can comment on or make changes to this bug.