Firefox 3 scrolling with fixed background images painfully slow and jerky after update from Firefox 2 whereas FF2 was perfect

RESOLVED DUPLICATE of bug 372039

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 372039
10 years ago
10 years ago

People

(Reporter: Steven Rowat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18) Gecko/20081029 Firefox/2.0.0.18
Build Identifier: Firefox 3.0.4 auto-updated from 2, on Windows XP

Perhaps this shouldn't be filed as a separate bug from 441460, however that one specified PNGs and mine are JPG background.

Simply put, scrolling suddenly became much worse as soon as FF2 was auto-upddated to FF3. All my pages in development have a fixed jpg background and all became painfully slow to scroll. 

This behaviour is sufficiently bad that I went back to FF2 for web development. FF3 scrolling is just too slow on the Thinkpad. FF3 no longer exists on this machine, since it seems to have been replaced by my re-download of FF2 (unfortunately).

I have a Mac also and FF3 might be marginally slower there than FF2 was, but it's not as bad and it's usable there.

Reproducible: Always

Steps to Reproduce:
1. Auto-update FF2 to FF3
2. Turn off auto-scroll and smooth scroll.
3. Scroll a page with a background image with CSS body, fixed.
Actual Results:  
Most obvious when there is a background image in body. I haven't tried other configurations since that's all I'm working on at present, and it needs to be there and worked fine in FF2 and in IE7 on windows XP and FF2 and Safari on Mac.


NOte that autoscroll and smooth scroll make it even worse than this - beyond unusable, if that's possible. :-)

Note that my autoscroll and smooth scroll settings were not read during the FF2->FF3 update, so at first they were 'on' (I'd had them off in FF2). This should have been done also, however that's a separate more minor issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372039
You need to log in before you can comment on or make changes to this bug.