Mail replies are sent to outgoing server acct instead of sending acct

RESOLVED INVALID

Status

SeaMonkey
MailNews: General
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Bill, Unassigned)

Tracking

SeaMonkey 1.1 Branch
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs reporter feedback])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.18) Gecko/20081031 SeaMonkey/1.1.13
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.18) Gecko/20081031 SeaMonkey/1.1.13

I have two accounts in SeaMonkey Mail, first@x.com and second@x.com. The outgoing server is second@x.com. When I send mail from first@x.com and the recipient replies, the reply is sent to the second@x.com inbox. I want it to come to the original sender's inbox, first@x.com. What's up, or how do I tell SM that's what I want?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(In reply to comment #0)
> I have two accounts in SeaMonkey Mail, first@x.com and second@x.com.
> The outgoing server is second@x.com.
> When I send mail from first@x.com and the recipient replies,
> the reply is sent to the second@x.com inbox.
> I want it to come to the original sender's inbox, first@x.com.

First, please read thru following MozillaZine Knowlede Base article. 
> http://kb.mozillazine.org/Mail_concepts
And, please report phenomenon with terms used by Thunderbird.

What is your "account"?
Account in Tb's definition? Or account(s) in contract with your ISP? 
What do you mean by "accounts of first@x.com and second@x.com"?
These are mail address(es) which is(are) assigned to "account(s)" (in contract with your ISP). It's defined/called as "Identity" in Tb's definition.
What do you mean by "outgoing server is second@x.com"?

Here is bugzilla.mozilla.org, is not support forum nor Help Center. If you need help, please ask for help at support forum such as MozillaZine forum first.
Do you use SMTP server of Gmail? If yes, it's Gmail's design.
(1) Accounts
    - Account-1        : mail_addr=x-1@x.com
    - Account-2(Gmail) : userid=mail_addr=x-2@gmail.com
(2) Send a mail of From:<x-1@x.com> via SMTP of Gmail using userid=x-2@gmail.com.
(3) Gmail replaces From: header by From:<x-2@gmail.com>, 
    unless you register x-1@x.com to Gmail.
(4) Because of From:<x-2@gmail.com>, replied mail is delivered to Account-2.
If you use Gmail, check mail header of mails in "Sent Mail" via Gmail's Web interface.

Updated

9 years ago
Version: unspecified → SeaMonkey 1.1 Branch

Updated

9 years ago
Component: General → MailNews: General
QA Contact: general → mail
Whiteboard: [needs reporter feedback]
(Reporter)

Comment 3

9 years ago
Good sleuthing. After reading your comment #2 I did track it down to a Gmail issue. To clarify, I have two TB accounts, each with one TB identity. Both account/identity was using the same smtp ISP login. When I changed each TB identity to use its own ISP login, it works properly. Thanks for digging in to this, and I do apologize if the answer was in the forums somewhere, but I didn't find anything prior to posting this bug report. You may close this issue.
Closing as INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.