No nsILoginManager component in Tb 3.0b1

RESOLVED DUPLICATE of bug 239131

Status

--
major
RESOLVED DUPLICATE of bug 239131
10 years ago
10 years ago

People

(Reporter: cbaker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081201 Thunderbird/3.0b1

Trying to access the nsILoginManager generates errors. Also, site passwords not saved in Tb Password Manager.  Master password appears to be saved, but I'm never prompted to enter it when accessing password fields.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



"var nsLoginInfo = new Components.Constructor("@mozilla.org/login-manager/loginInfo;1", Components.interfaces.nsILoginInfo, "init");" generates "Error: Invalid InterfaceID = NS_ERROR_XPC_BAD_IID"
Thunderbird has not yet switch to the toolkit password manager (See bug 239131).

What you mean by site passwords I don't know. Thunderbird does not have a built-in browsing mode.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 239131
(Reporter)

Comment 2

10 years ago
By "site passwords" I should say "password fields".  For instance, I am trying to save a site's password in my extension's options dialog window.

The extension will upload Thunderbird backups to Box.net and I need to save the login credentials.
(In reply to comment #2)
> By "site passwords" I should say "password fields".  For instance, I am trying
> to save a site's password in my extension's options dialog window.
> 
> The extension will upload Thunderbird backups to Box.net and I need to save the
> login credentials.

You could either use nsIAuthPrompt to prompt for the passwords, or you could hook into the existing wallet interface (see http://mxr.mozilla.org/comm-central/source/mozilla/extensions/wallet/public/).

However we will more than likely be switching Thunderbird to toolkit's password manager for beta 2. Although your extension would then work with 2.x builds.

If you have further questions, I suggest you ask on mozilla.dev.apps.thunderbird or one of the other appropriate news.mozilla.org newsgroups.
You need to log in before you can comment on or make changes to this bug.