Wrong context menu transparency

RESOLVED FIXED in mozilla1.9.2a1

Status

()

defect
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: mstange, Assigned: mstange)

Tracking

({fixed1.9.1, regression})

Trunk
mozilla1.9.2a1
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Assignee

Description

11 years ago
Posted patch patch v1Splinter Review
Since bug 391984 popup menu transparency is no longer implemented using -[NSWindow setAlphaValue:]; instead, we now make the window translucent and let -moz-appearance: menupopup / menuitem manage the transparency.

However, since the menuitems draw on top of the menupopup, their opacity gets multiplied. That means that the popup is now more transparent under the top and bottom padding than under the menuitems.

This patch adds a CGContextClearRect when drawing menuitems, as suggested in bug 391984 comment 5. This avoids the multiplying opacity problem.

Furthermore, I'm removing the popup window alpha stuff because we don't need it any more.
Attachment #353052 - Flags: superreview?(roc)
Attachment #353052 - Flags: review?(joshmoz)

Updated

11 years ago
Attachment #353052 - Flags: review?(joshmoz) → review+
Attachment #353052 - Flags: superreview?(roc) → superreview+
Assignee

Comment 1

11 years ago
http://hg.mozilla.org/mozilla-central/rev/62f5ef005bcd
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Assignee

Updated

11 years ago
Attachment #353052 - Flags: approval1.9.1?
Comment on attachment 353052 [details] [diff] [review]
patch v1

a191=beltzner
Attachment #353052 - Flags: approval1.9.1? → approval1.9.1+
You need to log in before you can comment on or make changes to this bug.