Tab switcher should allow switching pages with three-finger swipe

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

STEPS TO REPRODUCE:

1)  Open at least 10 tabs
2)  Click the tab switcher button
3)  Hover the tab switcher, and use a three-finger swipe on the macbook pro (or
    new macbook) trackpad, either up or down or left or right.

ACTUAL RESULTS: none of these have an effect

EXPECTED RESULTS: up/down behave like begin/end, while left/right behave like pgup/pgdown.  Or both behave like pgup/pgdown (like Preview).  Or something like that.

Updated

10 years ago
Depends on: 465076

Comment 1

10 years ago
What should happen here with the incoming ctrl-tab/all-tabs view? There won't be pages of tabs.

I would expect a swipe to perform an action (and not an intermediate selection because then how would you select a tab after swiping?)
If there aren't pages, then three-finger-swipe should probably do nothing, right?
So it's some kind similar to bug 468600? I don't know the new gestures so let me ask.
Hardware: PC → All
Version: unspecified → Trunk
Maybe.  Unlike the continuous two-finger scroll, a three-finger swipe does a pageup/pagedown.  The length of the swipe on the trackpad doesn't affect the distance traveled (which is always one page).
Interesting. But at least we should support both gestures so users with older hardware can also get in touch with it. Thanks Boris.
Depends on: 456520
Bug 465076 removed the pages from the all tabs view -> wontfix.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.