Closed Bug 469789 Opened 11 years ago Closed 11 years ago

Update "can't package this" message for the libxul world

Categories

(Firefox Build System :: General, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
mozilla3.6a1

People

(Reporter: philor, Assigned: philor)

Details

Attachments

(1 file)

Attached patch FixSplinter Review
Having the message when you make package/install/installer on a shared build say that you need a "--enable-static or --enable-libxul" build and then having --enable-static error out in configure is only amusing in certain limited circumstances; otherwise, it's just kinda mean.
Attachment #353171 - Flags: review?(ted.mielczarek)
Comment on attachment 353171 [details] [diff] [review]
Fix

I forgot that this message was in browser/installer. Oops! Could you add (Note: this is the default build configuration), so that people might possibly realize that they don't need to explicitly --enable-libxul?
Attachment #353171 - Flags: review?(ted.mielczarek) → review+
And me all happy that I got it down under 80 chars :)

How about "you need to build with "--enable-libxul" (the default if you don't specify --disable-libxul or --enable-shared) to package a build" (since I just read it aloud, and noticed the awkwardness of "build to package a build")?
"or --enable-debug"
Sigh. Bug 461309 built a bus stop before I could get my bikeshed put up, now I'll have to regroup.
http://hg.mozilla.org/mozilla-central/rev/994388063d68
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.2a1
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 3.6a1 → mozilla3.6a1
You need to log in before you can comment on or make changes to this bug.