Stop using dist/bin as a profile folder

RESOLVED DUPLICATE of bug 459114

Status

RESOLVED DUPLICATE of bug 459114
10 years ago
10 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
There are a number of xpcshell tests now that have to register a profile folder and a bunch of them are using the current process directory. This is bad. Not only does it mean it could attempt to use an app file for a profile file (I don't think we have any overlapping names now, but it could easily happen in the future), but also it means the profile can't really be cleaned up after each test run, making the order of test runs a little significant.

We should move to using a different directory that can be erased for each test run.
I filed this, and it has a wip!  There's a few issues that need to be worked out, and then it's good to go!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 459114
You need to log in before you can comment on or make changes to this bug.