All users were logged out of Bugzilla on October 13th, 2018

Dragging location-favicon proxy into bookmark panel results in grab

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: pirtepiraja, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4

Dragging a page avatar into the bookmark panel's drop-down menu (sub folder) produces a crash in X: the avatar "clings on" to the mouse pointer and cannot be dropped.

Reproducible: Always

Steps to Reproduce:
1. Grab a page avatar with left-click.
2. Drag it down to a sub-folder in one of your bookmark panel's bookmark folders.
3. Try to drop the avatar into the sub-folder. 
Actual Results:  
As described in "details". Crash.

Expected Results:  
Should make a bookmark in one of the sub-folders. Shouldn't crash.

I'm not 100-% sure it happens every time, but most of the times it does. I cannot reproduce it now, because I wouldn't be able to submit this report if I did...
(Reporter)

Comment 1

10 years ago
NO, it's not always reproducible. Could not reproduce it right away after reporting it. Sorry!

Comment 2

10 years ago
sorry. your actual results are strange.

if x crashes, you may see the screen blanking, most if not all applications will die and perhaps be restarted.

if this happens, http://viper.haque.net/~timeless/blog/143/

if the browser doesn't disappear then there were no crashes at all.

if you have a cursor and you can't fix the cursor, that's a different problem - a grab.
(Reporter)

Comment 3

10 years ago
OK, my bad, wrong term. It's a GRAB not a crash.

Updated

10 years ago
Summary: Dragging avatar into bookmark panel results in crash → Dragging location-favicon proxy into bookmark panel results in grab
(Reporter)

Comment 4

10 years ago
And yes, I'm sorry, I blew it: it's not an AVATAR but a FAVICON.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.