If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Google Talk Plugin] Hundreds of zombie "(open)" child processes saturate max process limit

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: nathdaninja, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

After start up firefox(3.0.5 and 3.1.2 beta) kick off zombie child processes listed as "(open)".  This continues until the max process limit is reached and all further open operations fail, for command line apps this results in the following error:

bash: fork: Resource temporarily unavailable

I have the following add ons:

Better gmail 2 0.7.2
DOM Inspector 1.8.1.3
de.lici.us 1.2.1
Flagfox 3.3.5
Quartz PDF Plugin 0.9.9.5
Session Manager 0.6.2.8
Taboo 0.5.9
Talkback 2.0.0.3

I have disabled all of these and the problem persists.

Apologies if this is misplaced or I have provided insufficient data, this is my first bugzilla report.

Thanks

Nath




Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

9 years ago
I have since managed to overcome the problem by booking marking all my tabs(100+), closing them and then reopening them from the bookmarks. The problem reocurred as I started enabling my add ons one by one and restarting. Better gmail and flagfox seemed to be likely suspects, altho the problem seemed to disappear again by enabling the rest of the add ons
(Reporter)

Comment 2

9 years ago
Have now traced this down to gmail.  Which I have tweaked slightly recently.
I installed the google video plug in for chat, and then unstalled it as my browser started crashing and I found several online reports about problems with that plug in.  I have also recently added the following 'Labs':

Tasks
Right-side chat
Right-side labels
Text Messaging (SMS) in Chat
Google Calndar gagdet
Navbar drag and drop

Disabling all the labs and restarting did not fix the problem, which is now reproducible if I have one tab open with just my basic gmail inbox page open.
(Reporter)

Comment 3

9 years ago
On further investigation I have tracked this down to the GoogleTalk plugin which I removed.  I could not find an uninstaller, so I simply deleted the plug in from my machine.  It turns out that the gmail is also configured when installing the plugin.  When the plugin is absent gmail does not fail nicely but keeps trying to detect the plugin causing lots and lots of zombie processes.   Not partcularly nice behaviour.

So not really a firefox problem, but I will be feeeding this back to google.
Something similar, only with there toolbar, bug 440090. Although in this case, does they're plugin officially support 3.1b2? If not, I imagine it'll be fixed by the time 3.1 ships.
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Summary: Hundreds of zombie "(open)" child processes saturate max process limit → [Google Talk Plugin] Hundreds of zombie "(open)" child processes saturate max process limit

Comment 5

6 years ago
Created attachment 572361 [details]
shows that the Google talk plugin is not stopping [before I stop it by killing it]

This happened today when trying to check my gmail. I have the Google plugin installed for a year or two now. I have never had this problem. This has been recent. I may try re-installing it when I can.

Comment 6

6 years ago
Sorry for re-living this old topic but  this has started to happen "On random moments" on the latest Firefox 7.0.1

Comment 7

6 years ago
UPDATE: I have updated Google Talk plugin via http://www.google.com/chat/video and it seems to have stopped. I would recommend that updating the plugin is a fix for this. Please change the status to this old bug. Thanks
WFM per reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.